X Carve will not connect to Controller

HELP!!! Waited a month to receive this X-Carve machine, spent the past three evenings assembling it roughly 6 hours per night and then I spent 2 more evenings trying to get it to connect. I downloaded Arduino, FTDI and easel drivers, but my computer doesn’t even recognize that I have it plugged in. Any advice would be appreciated. I tried to connect with two different computers, one running windows 10 and the other running windows 7. I even disassembled the X controller again to ensure all the wires were connected correctly. I am thinking it is a controller issue but I have no ideal, when I turn on the controller the light that says power does not light up but the fan works. Any suggestions would be appreciated. Thanks

First thing to do is check the EStop. That’s the big red button on top of the controller. Sometimes it appears to be disengaged when it not. Push it down to be sure. Then give it a twist and pull up with a bit of vigor(it can be stiff when new). You will hear a sharp snap when it disengages. I thought I broke mine the first time.

There’s also been some controllers coming out with a bad EStop. Search for Your original title or EStop. There is a ton of info on the forum. Good luck. Welcome to the rabbit hole.

Hi Curt, thanks, I tried the E-stop suggestion, still a no go.

Ok simple things first. Have you tried a new USB cable or a different port.

  1. if you have a micro usb cable, try plugging directly into the control board.
  2. if you have a meter, measure the power input to the board (the molex that has a black and red wire) and make sure it reads 24V
  3. Triple check the Estop. It shouldn’t have any play in it. You turn and pull it up.

I used the cable on a printer and it worked, I also tried all the different ports.

I tried on Win 7 last night and Win 10 tonight.

Here’s a suggestion, go to your control panel on the computer your hooked up too, Look for hardware and sound and go into that, from there you can check your autoplay settings, and also try to add new device while you have you equipment powered up.
Hope that’ll help you…

Hello Everyone, 1st and foremost “Thank You” I truly appreciated all the responses I received in regards to assisting me within getting my X-Carve up and running. The problem was a faulty E-Stop, once I contacted Invetables support they gave me an option that immediately remedied the issue.

I wired the E-Stop then removed the contact block and viola it lit up and I heard the machine motors lock. So once again thanks, this is a great forum community to learn and share.

1 Like