X-carve won't connect to Easel

So I finished the build and everything looks good so far, made the electric connections and the blue LEDs on the Shield as mentioned on the tutorial, downloaded the Easel app and installed it, now the problem comes when I want to try next step “Setup your machine” I get to the point where I select the Machine “1000mm”, “Dewalt 611”, “ACME”, etc. but after that it wont pass the “Connecting to X-Carve…Plug in your USB cable and turn on the machine.” window. I installed the Arduino IDE (?) and in the serial monitor shows the “Grbl 0.9j [’$’ for help]” message (I don’t know if that is correct) and I can move the machine with a Grbl Controller, I made a test by uploading a simple Circle program and the machine works so I dont think I have a problem with the Arduino or the Gshield.
I posted something like this in another topic but it was an old one and don’t know if would work so I am starting this one.
I’m running Windows 7 64 bits on a desktop, Arduino 1.6.7, EaselLocal 0.2.3 and trying with Chrome, Firefox and Explorer if it helps
I have read other related posts but most of them mention flashing the Arduino and such and to be honest I don’t know if that means to re upload the .Hex file but as I mentioned I don’t think (I hope) is an Arduino problem
I would appreciate any help
Thanks in advance


That is correct.

Easel Local version 0.2.3 has code in it to auto-detect the COM port where your Arduino is attached. It is a work in progress and does not work on some computers. You can try the following to see if it will fix your problem.

Uninstall Easel Local. version 0.2.3

Install Easel Local version 0.2.2


I am sorry, I meant blue and the 3 green LEDs

It worked!!!
Apparently with Windows 7 64 bits Easel Local version 0.2.2 works better than 0.2.3.
Thank you very much for your help!

1 Like

Actually before doing that, could you help us by posting a screenshot / copying the diagnostic info from Easel? You can get it by clicking the blue “Carve” button, scrolling to the bottom and clicking “Show diagnostic info”. This is what mine looks like for reference:

There used to be a problem with windows 7 and v0.2.3, but we thought we had solved the problem last week, so it would be extremely helpful if you could post this information for us (but make sure that you are using 0.2.3, not 0.2.2)

I am sorry, already changed to 0.2.2, during the week I’ll try to install the 0.2.3 and get the diagnistic info

I had this problem last night when connecting my machine for the first time. It would give me this error while attempting to connect using Chrome, I then tried Firefox and it worked fine.

I am having the same issue on Windows 10. I just upgraded to the X-Controller. I can connect to the Arduino gshield just fine. Reinstalled Arduino and Easel, no luck. Any suggestions would be great.

I’m having the same issue as you are having. Did you figure it out? if so, could you please share what you did?

I was using Chrome and was forced to update the Easel driver, don’t remember the version, and then my PC wouldn’t recognize my X-Carve anymore, not even with UGS 1.0.9, had to remove Easel driver completely and installed version 0.3.5 which solved the problem however now I need to use Firefox since Chrome won’t “find” my X-Carve