X carve wont move anymore


SInce a couple of months I’ve got an X-carve. It has worked fine the past month but today it just won’t move. I was cutting some 8mm plywood and suddenly it stopped moving.
My PC recognizes the X-controller and I can click Carve in Easel.

But when i want to cut something or home the machine nothing moves…
My motors got electricity, I can’t move them by hand.

Has anybody dealt with this before?

Greetings from belgium

Make sure that all of the internal connectors in the X-controller are fully seated. The retaining clips will close prior to full seating of the connectors.

Does your machine move freely when you have the USB unplugged? My machine motors are locked when the USB is plugged in.

All motor related connections are located on the same PCB as the Atmega chip. The ribbon cables are just for probe/limit switches and pause/resume. If it’s getting power (and it is if it’s showing green), then the motors should work.

Check the molex connectors at the back of the Xcontroller to make sure those haven’t vibrated out. Check all motor wiring for loose connections.

I’d also look at the machine inspector in Easel or even at the machine console to make sure entering a “$$” works. Maybe GRBL needs a reflash?

Hello, when I unplug the USB the motors move freely, the same when I unplug the power cord.

I tried everything. Today I plugged it back into my PC and suddenly it started working again. I noticed that the cables in the move and unplug the connectors at the Stepper motor side. after 5min it suddenly stopped working again. I already clamped down all my cables in the drag chain . I removed my power cord from my Dewalt spindle out og the drag chain to clear out any EM interference.

1 Like

Try checking all of your v-wheels and belt tensions. I had a problem where a similar thing happened because the gantry was out of square. Turning it off and moving it probably got it back in alignment and then while carving, it knocked itself out of square again.

Are the motor connections secured in place? I’d assume there was a locking mechanism on them to hold it in place. (I have the old Xcarve with wires and not a connector).

Also, make sure the pins are fully seated inside the connector. I’ve had the individual pins pop out on similar style connectors before.