X-controller burned up

Judt wondering if anyone else has had their X-controller smoke?

I had just finished a carve on 1/4" birch plywood from Easel. When I went to move the gantry up and out of the way so I could retrieve my project I heard a bang like a firecracker and smoke started coming out of my X-controller and my X-carve stopped working. Power was still on and I could hear the fan running. My USB connection was also still good. But the gantry would no longer move.

So I opened up my X-controller for examination and I found that one of the Toshiba TB6600HG stepper motor driver chips had exploded. (See photos.)

Hoping I don’t have to buy a whole new X-controller just to get the stepper motor board.

Move by hand or jogging in Easel?

Have you tried a bump stop and G28?

If the driver is all that went, you could replace it. Unfortunately, not a fix for most X-carve owners.

Jogging in Easel. Same with using the buttons on the X-controller.

I don’t know what you mean by “bump stop” and G28?

But, as you say, if the driver is all that went, and if I can’t simply buy a replacement board from Inventables, I’m comfortable enough with de-soldering and replacing the TB6600HG chip.

Beyond that, what concerns me is why the chip blew in the first place? The driver wasn’t under a heavy load when it went.

Its a big if.

Get in touch with Inventables, perhaps they can offer a replacement board.

Sarcasm didn’t come across.

How long have you had the x-controller? Running the machine, or moving by hand, wouldn’t cause a failure like that. Loose wiring? I’d guess something else on the board or you’re just very unlucky. As @HaldorLonningdal said, contact Inventables before you do anything else.

I’ve had the X-controller about two years. Never had a problem with it before. No loose wiring that I could find.

Contacted Inventables support before I started this thread. Waiting to hear back from them.

Just heard from Inventables and they are going to replace my board!

Two useful bits of information to share from my conversation with them.

  1. “… we find that a common cause of a blown stepper driver chip is when users move the spindle on the X or Y axis with their hands instead of Easel. This pushes electric current into the stepper motor chips and can easily overload them.”

In my case, however, I had NOT moved any axis by hand.

  1. “We have noticed a slight uptick in blown chips, but we’ve spoken to our engineering team and it’s impossible to pin a definite cause to it. So, it’s entirely possible that the ones on your board might have already been faulty to begin with.”

I think it’s absolutely marvelous that they’re going to replace my board! In the years I have been dealing with Inventables, their customer service has always been top notch!


Did you happen to find damage to any other components as a result? Mine unfortunately just did the same thing. As sad as I am to have it happen, I’m relieved this isn’t an issue that only I have had. Thank you for sharing the info that you received from them. I have already contacted them so hopefully they could help me out as well.

If it indeed is a faulty chip, l wonder if there is a way to trace the date code on the burned chips. If it is a bad run of chips, others with the same date code might be able to be warned.

Is there a way? Absolutely.

Is their process setup for that? I’d be surprised if it was.

We have full traceability on all our components at my work but we do aerospace electronics, not consumer electronics.

Most likely the cost of full traceability far exceeds the cost of just replacing the board and potentially just repairing or scrapping the board.

Hey Thomas,

I’ve had the same issue, I’ve replaced the TB6600HG chip, but now all motors will only move in one direction (when I instruct it in any direction via Easel it will send +X, +Y or +Z.

I’ve found the schematic, but I’m not skilled enough to figure out what else has blown. I have to presume it’s Auto Torque Reduction circuit because the problem is with all four motors.

Any advice would be gratefully appreciated. I have a replacement board incoming (thanks Inventables!), but I’d love to fix this board and get carving over the next week before it arrives.

Do you have the motors wired correctly?


I don’t know why that would cause what you’re seeing, but turn it off anyway. Set all your dip switch #4 switches off.

It could also be EMI. Do you have the stepper wires running with your mains AC line?

I will try tomorrow.

Btw, the motors worked fine before the driver blew and I haven’t changed any of the wiring since.

So you removed and replaced the driver? Any chance there’s a solder bridge or other issue with the replacement?

Yes. No solder bridge and it’s a new chip, but I’ve no way of testing it. It was the Y1 driver that blew, but the issue is with all motors now.

Hello RachelRayns…Inventables replaced the part no questions asked…installed the new board and it worked just like new! Until a couple days ago. Was working on a project and it stopped midway, heard a couple pops and started to smell that familiar burning electric smell. Same thing happened again for the second time. Same chip in the same exact spot. I have yet to hear back from Inventables about what’s gonna happen this time around. But I have no clue what’s causing this to happen. I had someone replace the burnt out chip with an undamaged one from the last board and now I can’t get any connectivity to my laptop. I’m at a loss. As far as your issue with the motors, I am in no way skilled enough to give you an answer. Hopefully someone out there will be able to figure this out.