X-Controller DOA(Resolved)

X-Controller Power LEDs OFF Is the only topic I found on this issue. I have no power led on either panel. Supply is on, fan runs. I tried everything mentioned in the topic above but no change. I took some photos and measured voltages. I assume the limit XYZ should have the same voltage output. Any thoughts? I have a support email in to Inventables.

Hey, is the emergency stop button connected and in the up position?

1 Like

I had the same problem, you have to twist it pretty hard. Also have to hit it harder than you would think to stop!

The LED on the PS interface board is powered by the 5V from the main control board. So therefore, there might be a few issues:

  1. Your Estop is engaged as others have suggested. Make sure its in the “On” state. It can be a bit stiff.
  2. Your ribbon cables are on wrong. Based on the first picture you posted, the cable looks like it might be reversed.

Looking at the picture from the instructions:

Your Pin1 is correct but the cable is flipped orientation which may mean the cable on the other side is reversed as well.

The cable ends, at least on my Xcontroller, were not interchangeable. Verify the orientation and ful seat on both ribbon cables (the cables need to be pushed in more even after the retaining clips engage.

As for the Estop, it eventually does loosen up a little and becomes easier to engage/disengage. I personally hit both the Estop and the main power switch when I’m done using my Xcarve. I’ve not had any issues doing that.

Thanks for all the suggestions. I actually removed the estop button from the switch module and still have the same problem.

I also tried a couple of different cable orientations before posting and checked the seating. I will however look at the pinouts and ensure they match.

Woo hoo!!! I see the problem from your picture. I have the cabled swapped on the controller board.:flushed: made the change and all is good. Got to go back and review the directions. Don’t know how I did that.

1 Like