X-controller electrical gremlins

Every thing was fine yesterday and for about a year before that. Today when I went out to my shop my relay to turn on the spindle was making a clicking/grinding sound. E-stop and power switch on the x-controller are both in the off position. Removing the wires connecting the x-controller to the relay stops the noise, removing the power cord from the x-controller stops the noise, removing the usb cable from the x-controller also stops the noise. Plugging them back in starts the noise back up.

Powering on the x-controller seemed to fix the issue with the relay, if only temporarily, but homing the machine failed. At first it was just the Y axis that failed to move, I thought it was the micro switch so I replaced it and tried again. This time both X and Y failed to move. So I turned everything back off to check wiring again, which started the relay noise back up. All the wiring seemed fine so I powered everything back up. The noise goes away but homing only moves the Z axis down, instead of up, like 1 mm and then fails.

I ran a few carves and they all seemed to work fine. Iā€™m at a loss. Any help would be greatly appreciated.

Check all the grounding. Sometimes a loose wire will cause intermittent shorts and other strange behavior.
Also if your getting any noise from the motors then it will make homing next to impossible. I rewired my motors with shielded cable to get rid of this noise issue I had.
Phil covers a lot of this in his posts. Check them out there is a lot of good info there.

1 Like