X-Controller loses connection all the time

Hi guys,

I k now there a some threads about this problem, but none solved mine.
I lose connection in the middle of a carve, the button “carve” in Easel turns blue. Then i have to unplug the USB and replug it.
I bought an powered USB hub and a new USB Cable, but it’s still the same. Completely new circuit for the X Carve and its components. USB ernergy saving is turned off. I even tried to use it without internet connection.

The strange thing is, some projects works fine. I made a design which I use several times a week without any trouble. I cant imagine my (hardware) problem is caused by a broken file?!

Maybe someone has the same problem and was able to fix it.

Kind regards and have a great day


USB-port power management checked?

Yes, energy saving ist turned off.

Dewalt 611? Long run time, RPM setting?
Checked its brushes?
Fluorescent lighting in the room?

However - when I have had RF noise causing interrupts my Carve button go blue, then come back on again. Not sure RF-noise would cause the USB port to freeze though…?

Dewalt 26204 (230V 611 Version), I renewed the brushes about 2 month ago. 30 in/min, about 30min carve

I do have fluorescent lighting, but they have been there all the years. I installed a new circuit exclusively for the X Carve and its components, still got problems. Very frustrating :-/

Absolutely, I can kill my USB-connection when I turn my lighting off (DIY Ardunio controller)
But I have only one circuit available for my room.

What RPM setting do you use most frequently?

I carve at about 18000 RPM, its number 2 at the routers selction wheel

BTW - have you tried bypassing the front panel USB-plug?
You need a MiniUSB to connect directly onto the board IIRC.

I run a Makita and at higher RPM (>22k) I get random disconnects also, so RPM may play a role if its RF-noise related.

1 Like

I summarized my experience with this here.

Two question at first:

  • are yousure about the power management? The usb root hub is a separate option and not part of the general power management settings
  • did you try bypassing the USB bulkhead of the controller?
1 Like

Guys, thank you very much!
The front USB might have been the problem. I connectect it directly to the board, now it seems wto work since, the last 3 carvings had no interrupt.
But as I unmounted the X-Controller case, there was a huge dust cover on the board, which might also causing trouble. @DominikMai maybe you should add this to your great list in the link

If you guys ever visit northern Germany, beer is on me! @DominikMai @HaldorLonningdal

I’m glad it worked!

I’ll hold you to that, greetings from Saarland :wink:

Make sure all the connections are tight. I had my red wire to the touch sensor come loose and it stopped the carve.

What windows is your computer running?

Win 10

But as mentioned, i fixed the problem already :slight_smile:

:+1:t2: I just thought if I say something, I will also qualify for beers in Germany :wink:


We are a community, feel free to pick up your beer :wink:

1 Like