X-controller Problems

I just finished my build yesterday night. Plug in the X-controller. everything was a go. as i was going through the set up of the X-controller. moving the XYZ. she was ALIVE. for about 2mins. now there is no green light anymore. i took it apart. and rebuilt it 10 times already. still no lights. only the fan runs. look at many forums on the subject. installed drives. and nothing works. smh… ITS ALWAYS SOMETHING.

Did you check to see that the E-Stop is fully disengaged and didn’t get nudged?

1 Like

Yes. like 50 times.

The fan running indicates the power supply is working.

Do you hear the steppers engage when you turn on the Xcontroller?

Have you called Inventables Customer Success? They’re usually very helpful.

They are going to build me one. test it there to make sure it works. then ship it to me. but i hate waiting. if i can get it working. i dnt have to wait. i already waited a month.


imma put it back together in a sec.


when i first hooked it up. yes i did hear the steppers engage. but after that. not anymore

Where’s the red button part of the Estop?

Also, connect the USB bulkhead to a computer. The lack of USB may have the Arduino in reset.

Yeah, I don’t think mine engages until it is plugged to a USB

Hard to troubleshoot from the office though =p

1 Like

I am having the same problem! I still can’t get mine up and running. I plan on calling after I get out of work because like you, I’ve waited over a month to get all the parts. Everything worked for a couple minutes and then nothing. Fingers crossed I get the same response as you and get one pre-built and tested.

1 Like

yeah. i hate spending that much money. and waiting a month to get something. and when i do get it. it dnt work. it sucks. i hope i get this working.

I guess I better prepare myself for a headache when I get mine just in case. Thanks for the heads up guys!!! Funny, I just got it from ups. Let the games begin!!!

1 Like


I wish you all the luck. your going to need it.

1 Like

2nd issue in 2 days. Something is off.

1 Like

You having problems too.

No. Spent time yesterday working with someone else on any and every other possibility. He is have same issue. Board powers up and fans do, but stepper motors don’t engage and lights don’t come on. His worked for a little before hitting the estop. Same symptoms as yours even taking the estop out of the equation didn’t solve it.