X-controller Problems

Yes. everything worked. i was moving it around. then it just stop. never moved or came back on after that.

So instead of inventables givng me a pre-made X-controller. They had me over night ship. my X-controller to them. So they could get down to the Bottom of this problem. They’ve had multiple calls with the same issue that i was having. from there testing of my X-controller. They replaced the estop cable. It had Bad crimp. So now my X-controller is up and running. and will be over night ship to me. And i should have it here tomorrow.

2 Likes

Everything is a GO… GREEN LIGHT is on. Time to have fun…YAY.

https://discuss-assets.s3.amazonaws.com/original/3X/b/c/bc69f566c2eb24422dd036899b9d0c88c8f691b9.mp4

My issue with the xcontroller is I can connect with my wife’s pc right away, but can’t with my new laptop I bought for this. Sounds dumb right, sent help desk an email.

that sucks. did you install all the drivers

I followed the page for the setup on her pc, got it working. Bought mine did the same exact thing, nothing happens, motors stepup, xcontroller on, yada yada yada, unplug from mine to hers poof make the machine work again

Does the Xcontroller show up in the Device Manager on yours at all?

1 Like

Oh boy, I just received my X Controller two days ago (the 5th and final package lol) Sounds like im in for a treat!

1 Like

yes it does

@RandallWhitehead
Do you have anything else open? Or multiple instances of Easel?

@NeilFerreri1 the driver wouldn’t download, did it manually, update computer, wait for another restart 2 hrs later it’s working, now just have to make this 2 stage carve work

1 Like

I’ve just assembled my brand new x-carve (1000mm kit) and I am having the same problem… The light is green, the fan is running, I can hear the motors when I turn it on, but nothing, I can’t run the setup on easel (on my MacBook pro), there’s a message saying connecting but nothing happens… I’ve tried to check the e-stop button, bypass it the button, another laptop, another USB cable (also direct on the board), but nothing… It is so frustrating to have a machine without work as it supposed to… I sent a message yesterday to help center but still waiting their answer.

Make sure that you are trying to connect at 115200 baud.

If that’s ok then try installing/updating the FTDI serial port driver.

Thanks LarryM, but I have no idea how to do it on MacOs. I’ve seen that 115200 baud it is something related to the USB speed rate, right? Could you tell me more about it this procedure? Thanks again

Yes it does. I don’t use Macs, so I can’t help there. Maybe someone else can jump in on that one.

Most gcode sender shoulds set the Baud rate correctly by itself afaik. Nevertheless you should be able to set the Baud rate manually in the device manager in Windows for your port (not in my workshop until weekend, so I can’t check now).
Should be something like: open device manager, COM port, right click, properties, then the second tab control (don’t know what it’s called in an english windows, should be something like connection settings or anything similar)

He is using a Mac.

Oh sorry my bad I didn’t catch that.

1 Like

A quick update: After talk to the inventables support team, we figured out a conflict with my wacom tablet driver. After remove the wacom driver I was able to setup on easel. Now the x-carve is working great, but I hope Inventables team will find a solution for the wacom users!

2 Likes