X controller shutting off

Anyone have issues with their x controller shutting off on it’s own?
I have to turn it off and on a few times ro get it working again

Just something I’ve personally experienced…I’ve had my router wire contact the cable that connects to the controller. During a carve, due to the back and forth of the gantry, the controller cable was able to work itself loose due to that contact, causing the controller to shut off. I’ve rerouted things to make sure that doesn’t happen again, but it sure was a head-scratcher for a few minutes.

All cables are clear of all movements. This is one of many issues I have.
Another is it freezes at tooth path simulation gets 3/4 of the way and sits there until I shut it off and stop for the day
homing the z - Sometimes I have ti assist it
the carve stops mid way
and the issue above

Tool path simulation seems like maybe a sender problem. Are you using Easel? Have you checked all of the connections inside the controller box and the wires going to the controller?Have you tried a different USB cable? Kind of stabbing here since I haven’t experienced the issues you are having. Maybe contact Inventables?

Thank you for the reply. Have tried it all. Inventables thinks it may be a faulty emergency switch.
Think today I’m just going to bypass it as I just got an order of 4 signs to punch out for tomorrow pickup.