X controller x and z axis not working

I just got my x controller assembled and plugged in and went through all of the instructions several times and updated my easel driver to 0.2.7 and went to the machine set up and input my machine info, went to the page where u test your axis movement, and the only one that would move is the y axis.
I’ve searched for soulutions but nothing thus far.

Another problem was that when I wired the axis the way it showed in the upgrade instructions (from left to right if facing back of machine: black, green, white, red); the y axis moved backwards.

I don’t yet have the extra cable to run the fourth driver so I just left absolutely everything alone on the x controller but I did crank the y axis pitientiometer up all the way as stated in the instructions.

But in the instructions for adding the extra wire, it shows all of the wires for all axis wired complete backwards as I prievious mentioned, so this way it goes red, white, green, black.

I figured I’d try that was, and when I did, my y axis moved the right direction but still nothing from any other axis. And I mean absolutely nothing at all what so ever.

So before I get to upset and wreck something lol I figured I’d stop and ask the fine folks of the forum!!
Any ideas? Anyone else with this problem?

Bahahaha so I just went back to my garage to close up, and I thought…geeee I wonder if I ever hooked the wires back up in those motors when i did some other re wiring?
Of course I did not!!!
I can’t believe I am THAT guy hahaha!
Well no time to hook them up tonight, but I’m pretty sure that’s my problem lol
Time to delete this post before too many people see how dumb I was!


Hey Casey

Don’t delete… this is just a reminder that we are all human…:slight_smile: and will probably serve as a good reminder for future X-Carvers as well.

PS I am the guy that cut my stepper motor wires too short… like 4 feet too short. (doh!) Guess what I spent 3 hours doing… yup…splicing and re-wiring…

Live and learn … Get’em tomorrow.


I think I will keep it as I would still like to point out the discrepancy with the wires being wired different than the shown picture for wiring without adding more stepper cable.
For wiring the cables to the x controller, I had to try by error to find out that u need to follow the wire order as shown in pics for adding more stepper cable, and not the pics shown where u just use the X controller as it comes. Both those pics seem to have complete oppoosite wiring order, only 1 worked for me.
I should also point out that if you want to make full use of the x controller, you have to buy more stepper cable which I did not as it does not say anything in the description of the product. And it certainly should!!! Especially for people like me who live in Canada and don’t want to spend $28 American to ship just a few feet of cable!!!
They said they were gonna send me some wire to say sorry, but that was a couple days ago, and I haven’t heard anything more, or gotten word that they have Sent it or anything.

18/4 shielded security wire from a local hardware store works as well. I ended up needing to get around 10 feet of cable for mine due to where I wanted to put my Xcontroller and it was identical to the stepper wire from Inventables.

Thanks for the suggestion of wire…I was actually gonna go get some yesterday, but the day before, inventables offered to send some to me. I had a relay in my cart already and even offered for them to just send the wire in that package and that I’d pay for the shipping but they never got back to me on that after they offered to send it in the first place, and I even sent a second email asking if they would just slip it in my package that I will pay for…so I just found a relay somewhere else, and I guess I’ll go to the hardware store and buy the wire from there aswell because I guess I’m not hearing back from inventables.
I even offered to pay the shipping that is an astounding $28 u.s (I didn’t mind because I was buying a relay anyways) but at least I got everything I needed for much cheaper when I went elsewhere because I didn’t have to pay exhange rate and shipping etc.

1 Like

I just went and connected all my wires I missed, and to no big surprise, my machine is working!!!
I went through the easl setup and my prob worked first try, and now I just need to do a test carve, but I have complete faith at this point.

Inventables got back to me and they did offer to send me more wire and apologized for the late response and gave me more info on questions I had, and all is good there now also!

I’ll post back when I use the x controller a bit and see how she goes!


I got to using the x controller a bit, a d so far I’m extremely happy!
It’s fantastic having a pause button etc, and the extra power is very nice indeed.
The only thing I currently don’t like, I mean I absolutely hate, would be the power button.
The power button being at the very back, and inbetween wires on each side of it makes it very annoying if your controller is under ur bench or whatever.
Although it was designed for the new x carve side mound etc so I really can’t rag about it too much as it’s not being used in the position it was designed for.
I’ve had to use the emergency stop button also lmao and it was handy aswell!!
Windows 10 keeps screwing my programs up and after last nights update, u.g.s is having problems now also…anyone else have that happen?