X settings and dimension gets doubled

So I just assembled my xcarve and i did the first test run on a small design. everything seamed ok but looked elongated in the x direction. so i drew up a 1" x 1" square to see what happens.
the square is 3’’ in the x direction from the origin and 3" in the y direction from origin.

when i run it on the xcrave the square turns into a 1.9’’ x 1’’ rectangle and its coordinates are x=6 , y=3 !! Its like the x axis gets doubled… Please help

I also relized when jogging 1in it moves 2in this only happens in the x direction

Go to the Machine Inspector and type in “$$” and press enter. Paste the settings returned or an image of them here.


Brandon Parker

here are my settings i changed the $100=20 instead of $100=40 im getting it closer but i don’t know if that’s the correct way

  • $132=100.000
  • $131=750.000
  • $130=750.000
  • $122=50.000
  • $121=500.000
  • $120=500.000
  • $112=500.000
  • $111=8000.000
  • $110=8000.000
  • $102=188.976
  • $101=40.000
  • $100=20.000
  • $32=0
  • $31=0
  • $30=1
  • $27=1.000
  • $26=250
  • $25=750.000
  • $24=25.000
  • $23=3
  • $22=1
  • $21=0
  • $20=0
  • $13=0
  • $12=0.002
  • $11=0.020
  • $10=115
  • $6=0
  • $5=0
  • $4=0
  • $3=3
  • $2=0
  • $1=255
  • $0=10

Check the dip switch in your controller. You want 1&3(only) to be switched ON for 8x microstepping on the X&Y. Only 2 should be ON for the Z.
Change $100 back to 40.

1 Like

Dip switches are correct

Microstep setting (dip switches) dont have a single “correct” setting as the travel is a function between the dip switches and the $100/$101/$102 GRBL parameters.

So set the dip switches to their default position and then adjust the GRBL parameter for the axis in question.
$100 = X axis
$101 = Y axis
$102 = Z axis

Default values for those are 40 (X) / 40 (Y) / 188.976 (Z)

As Neil suggested, change $100 back to 40 (its now 20)

Yes after reading online I found what u guys are talking about. But the issue arises when I put it back to 40! My machine works good when I put it at 20. I even calibrated it and my value calibrated is $100=19.95. Could it be anything else that causing it to do this?


Your two variables are microstep setting and GRBL value.
You change either microstep or GRBL value to match size.

The controller uses the microstep setting to manually set how many pulses are sent to move the motor. (hince microsteps).

the software (GRBL) has a value to fine tune how much the motor moves for each pulse ($100=?)

once you set your manual dip switch to determine how many pulses are sent to make one revolution then you calibrate to ensure the most accurate movement for that setting.

I am sure there are some better explanations for this but this seems to be the most simple.

Are you using a different pulley on the X?

Nope using the one that came with the x-carve

Can you flip the Dip switches and flip them back?
You also most likely want #4 to be off. That’s your idle torque reduction. With it on, your motors are easier to move accidentally during a tool change.

yes i tried switching them off and on making sure they were not stuck. ill change #4 thanks for the info