XCarve does not move when sent gcode file

Hi guys, I am tearing my hair out trying to do my first carve.
My machine seems to be connected and working fine when jogging with UGS. The issue starts when I load a GCode file and send it to my XCarve. UGS shows time elapsed and time remaining and ticks away but the XCarve just sits there doing nothing.
The GCode was created in Vectric Aspire using the XCarve mm Post Processor and if I run it in a CNC simulator it all runs as it should. I am completely stuck and having watched tutorials etc I just can’t find what is going wrong. I have attached the GCode file and would appreciate any help to resolve my issue. Many thanks.
HouseSign500x300x18.gcode (204.9 KB)

I personally would delete the T1 in the first line. I’d add a G90 too. I’d get rid of the S code if you don’t have a spindle that can be controlled internally, and the M3 as well in the 5th line.

I have found that it’s just easier to remove all the codes that aren’t necessary. Many of them don’t seem to work in my version of UGS including m5 and m30.

Thanks Martin - Your advice worked (almost)!
Off went the spindle and it carved ‘Cot’ before it stopped again but at least I know why it wasn’t working.
Looks like I will just have to learn more about GRBL and what these extra lines of code do.
Your help is much appreciated,

Try using the Easel post processor.

The Post Processor I use is listed in this thread. Not the JTech ones but those below them. Works just fine and no edits required - Xcarve_JTech_grbl - latest release (9/1/2017)

Thanks Mark but Unfortunately i have no interest ernet in the shop so i dont want to use Easel for anything. I have heard that using the easel pp with ugs causes a lot of problems.

Thanks for the link Ray, hadnt found that one so i will give it a try tomorrow when i am off work.

Sorry, I did not realize Easel was not an option for you.