XCarve hangs on writing machine configuration in Easel

Hey all-

Just finished upgrading my Xcarve and to the latest iteration and added an XController. I updated my drivers, and actually made a couple of successful cuts to check my dimensions, but now I’m having connection issues. Easel sees my machine, but hangs on writing the configuration in the machine setup tab. If I try and connect via UGS, I can connect, but get a continuous string of IOException while sending status “null” errors. This occurred after I tried adjusting the steps per mm on my Y axis to dial in in. Tried swapping USB cables too.

Edit: I get an "error while processing result " error if I try and do a soft reset in UGS.



Shouldn’t have had to.

When I tried to reconnect, it didn’t show up in the easel tab. The device still showed in the com port, so I tried going back through the machine setup. When I opened that back up, I discovered it no longer had my original configuration saved, so I tried it again. That’s when I discovered that it hung on writing the config. After the config had hung a while, I cancelled it. I got the green Carve but back, but get no response from the machine. Can’t even jog it

Tried rebooting the laptop it’s connected to also.

1 Like

Healed. Flashed the Xcontroller via easel and it seems to have resolved it.

1 Like