Xcarve_JTech_grbl with 1.1f features?

Continuing the discussion from Xcarve_JTech_grbl Update (11/12/2016):

Does anyone know if it’s possible to get 1.1f working with a JTech laser?

I just updated my stock 0.9 grbl to 1.1f, hoping to play with the new features, but I seem to have lost my PWM abilities… I used to be able to set the power level with M03 S1400 etc, but now it only wants to do full power.

I see there is a Xcarve_JTech_grbl hex download, but it seems to be based on 1.0c and I am dying to try out the new 1.1f goodies!

Please forgive me if this is all documented somewhere obvious, but I couldn’t find it.

(I have a 2.8W j-tech laser and a X-Carve 1000)

Check the rpm range ($30 and $31). The official 1.1f should function well with the JTech laser it’s just a little slower than the 1.0c version.

Actually, check all of the grbl parameters. You probably don’t have a version of 1.1f that is built for the Xcarve.

I wrote Grbl v1.1 with a 2.8W Jtech laser and used parts of their laser code as well. It’s fully compatible. Make sure you enable laser mode via $32=1. And read the laser wiki page, because it behaves a little different to add a bit of safety. Also try using M4 dynamic power mode. It’s awesome.


Thanks for your advice! Good to know 1.1 is fully compatible.

Strange issue: I’ve now set $30=255 and $31=0, which fixed my PWM issues, but when I enable laser mode with the $32=1 command, the laser won’t turn on at all. However, with the laser mode disabled, it works properly…

I put the 1.1f build together with almost zero idea what I was doing, so maybe I’ve got it wrong. I’m using the xcarve defaults in the config, and I set the DEFAULT_SPINDLE_RPM_MAX to 12000. Should I have used 255 in the defaults? I presume the $30=255 command overrides that?

Please read the Grbl Laser wiki page. Here’s the link. It explains why the laser doesn’t turn on.

1 Like

I did read the wiki page, but I must be missing something, because all my motion is G1 and it moves without stopping (which I love - it’s like a whole new machine) even though laser mode is disabled. It’s not really a problem, since it’s working great, but just a little confusing.

I highly recommend that you use Grbl’s laser mode when using your laser.

First set the spindle as enabled with a power setting M4 S100. (It won’t turn on yet.)
Then, issue a G1 move like so G91 G1 X1 F100. It should turn on during the motion and turn off automatically when at a stop.

1 Like

I have 1.1f running with Lasergrbl and it works great. The only problem I’ve had is the same as you. I need to turn on the laser in order to focus it. I know you have to have a motion code done before it will turn on. Obviously you can’t focus it while it’s moving.

This is what has worked for me, and someone please chime in if there’s an easier way.

First I enter a command using G1. For example I use, G1 X1 F1000. This will move the X axis just a small amount. Then when I use M3 S3, which sets my JTech laser to the lowest setting, my laser comes on and I can focus. This has been the only thing that has worked for me. Of course use M5 to turn the laser off.

I hope this helps!!

These are the settings I use for laser mode and it works great. It won’t turn on because you first have to use a motion command before the laser will turn on.

What’s awesome is that grbl 1.1f will work in Easel as well. I’ve been able to switch back and forth between the laser program I use and easel without reflashing.

Using M3 is the recommended way to turn on your laser for focusing. To turn it on there are two ways. You can issue a G1 move before it, but you can also just send a G1 Fxxx command without any XYZ axes. Any following M3 Sxxx command will instantly turn on the laser and keep it on for focusing. The other way is, if your sender uses Grbl v1.1’s new jogging commands, jogging will also turn on the laser, if in M3 mode beforehand. So, issue an M3 Sxxx command and jog into position where you want to focus. The laser will turn on upon the first jog move.

Awesome, thanks for the input. I’ll have to give that a try.

I haven’t moved away from Easel yet but I know once I do I’ll probably do something like this.

I know this is an old conversation but the answers here sound like everyone knows what they are doing. I just purchased and installed the JTech 2.8w laser. It installed without an issue but my problem is the laser is always on. I have emailed JTech and they are telling me the problem is in the X-Controller and Inventables support say they don’;t support the laser. I have tried the M05 command to turn the laser off and the console says OK but it is still on. I turn it off with the safety key. If I turn on the laser module and turn the key on the laser stays off but as soon as I power on the X-controller, it turns on with no software running on the PC. Any suggestions or ideas?

This is true and is made clear by a statement on this forum from Zach Kaplan (CEO).

You can use a laser quite effectively with the appropriate software.

there is a switch on the laser control board that is used to select CW (continuous wave) or TTL. That switch needs to be in the TTL position for computer control.

For best results you need to use a version of grbl that supports lasers. Since you are just getting started load this version of grbl into the X-controller.

After you get it all working you can move up to the complexity of using a laser with 1.1f

Thank you for the quick response.

The mode switch is in the correct position. Working with J-Tech, we have tried multiple things without success.

I don’t expect Inventables to support the laser components themselves but I figured they had worked with J-Tech on the control leads and signals at least enough to make suggestions. And last night I received emails from both companies with more suggestions. I’m not complaining about the support of either companies, they have both been very responsive. I have read so many ‘piece of cake’ stories on the installation of the J-Tech laser on an X-Carve that I am getting a little frustrated.

I will try their suggestions first and then I will load the software you pointed out if necessary. I really appreciate the help you have given. Please don’t feel I am slighting your suggestions but I’d like to keep the latest version if possible. I will update this thread when I try everything.

Not a problem for me. Each piece of the puzzle has variations. One picks the solution that fits them best.

The goal here is to get you working the way you want to do it.

This documentation will help in your decision with running 1.1f

Keep in mind that the anomalous behavior of 1.1f is isolated to the laser mode of that release.

I did some checking and pin SPINDLE (PWM) always has 4.75 volts on it when the controller is turned on. I found no commands that would turn it off, M05 doesn’t work. So I emailed Inventables again and waiting on their response. If they can tell me how to turn it off, I’ll move on to the software solutions.

Thanks again for responding.

You can do your static testing in spindle mode which eliminates the laser modifications on the PWM signal.

Check the internal cable connections in the X-controller to make sure that they are fully seated. The cable strain relief clips will close prior to the cable being fully seated. This has been an issue for lots of people here.

In spindle mode the controlling G-code for the PWM signal is the M3,M4,M5 commands and the S word.

In spindle mode, M3 S(max) should keep the PWM signal high (close to + 5 volts) and M5 should turn it off (close to zero volts).

I would suggest using PicSender to send commands. It has switches for laser and spindle modes.


They are great at help troubleshooting and a cornucopia of information!