Xcarve losing machine Zero. Issues with homing

I have recently put together my x-carve (1000mm) and been experiencing problems with homing and machine losing it’s zero… I use DeskProto for generating the g code and UGS for executing it. It starts of fine and then randomly offsets itself, losses its machine zero, and can’t seem to preform homing cycle again ( either z-axis starts going opposite direction and thinks its homed without hitting the limit switch or x-axis stops in the middle and makes noise like its hitting something/jumps in place) .

So I’ve tried tweaking current on the stepper motors.Now, it hits all the limit switches however, when it hits Y-axis switch the motor keeps “jumping” in one place, without being able to signal the completion of homing sequence. After I stop it I am not able to move any of the axis until I restart UGS.

I have also managed to complete one or two projects without an issue, when machine randomly decided to work. When that happened it seemed like Z axis has cut a bit deeper than it was supposed to…

Completely lost on what the issue might be. Any help/suggestion is greatly appreciated! Thanks!

Try to do a couple test cuts in Easel, that will help you determine if you have either physical or programming issues, or both.

If it’s a physical issue, you may have belts too tight (or loose), the pulleys may be slipping on the shafts (check set screws are tight and on the shaft flats), the potentiometers may be too low (or high), or a few other things. It’s hard to know without more details or pictures.

If it’s a programming issue, well, someone else can help with that. I’m just an Easel user for now. :smile:

There are a couple videos addressing belt tension and potentiometer adjustment at X-Carve Maintenance/Troubleshooting Videos - Add Your Own! that may help you.

If you can post some pictures of the problem cuts, and a description of your machine (spindle type, speed, bits, etc.), we should be able to give you more detailed help.

Sounds like the spindle is giving out electronic noise. are you using the stock spindle? (If so it may be going, there was a problem with them)

@BrianSaban @RobertA_Rieke Thank you both! I am waiting for the weekend to see if your suggestions might be the answers to my problem, and hopefully there will be no need to post pictures…

Robert, great tutorials! I’ll try to follow and adjust my potentiometer, since I suspect that might be my issue. Brian do you mind expanding a bit more regarding spindle issue or directing me to where that topic was covered? I’m using the standard spindle (DeWalt 611) that comes with “fully loaded package”.

The problems were with the 24 volt spindle that originally came as the standard spindle.

The DeWalt 611 doesn’t have those problems.

I appologize. I do infact have 24v one. I didn’t realize that the list of options under “configure yours” when selecting parts has been updated … I just remember that the spindle I got was on top of the list… Anyway, sorry for confusion… It is 24 V afterall

the spindle isnt running when your doing the homing sequence. sounds like something else is going on for at least that portion of events

So, I have adjusted the potentiometers as per @RobertA_Rieke tutorial. It seemed to solve some problems but not all. Firstly, I am curios to know what is the relationship between limit switches and motors. I have noticed that adjusting the voltage affects also how limits behave. No more jumping on Y axis, but Z still occasionally will move up, and without even touching the limit switch think it’s homed. My last attempt to cut something has resulted in Z axis dropping lower and cuttin deeper as it progresses, looking like it’s losing steps and slipping…(as shown in the picture). Granted, I have not measured how many Volts I am putting into each axis/motor…I have adjusted it just based on observations on thermal overload and tried to put it just in the middle…

The Dewalt 611 is heavier than the old “standard” spindle. Is there any chance that either the spindle is dropping down in the mount, or the bit is slowly slipping down out of the collet? The heavier weight of the router may require you to dial the Z-axis pot up a little higher, but I don’t have mine on yet so I don’t know for sure. Some standard advice would also be to check the v-wheels to make sure they’re not too loose.

For your project, what feeds and speeds are you using? Are you using Easel, or another program?

As for limit switches, they’re really “homing” switches if you set them up per the directions. True limit switches will kill power when they are tripped in order to save the machine. As homing switches, they are used to locate a true origin point of X=0 and Y=0, and to ride the spindle all the way up to the Z switch. You would still have to zero out the Z axis on your material.

Check the set screws on the z-axis pulleys they can come loose and give the appearance of missing steps or dropping too deep as well.

It’s definitely not the bit slipping, since the collet starts hitting the material. And I have misspoken regarding my spindle.It is not Dewalt but standard 24V. I am currently running the machine at 7500rpm and 100 inch/m.

I understand zeroing systems ( machine zero, work zero…) I do not however understand how does a limit switch gets tripped without being touched, or how does a tripped switch fails to signal completion of homing, and as in my case , makes y axis to jump in one place after being pushed. Right now, whats happening ( this happens with Easel too) is that z axis moves upwards and without touching the switch, signals successful homing of z and then it moves to x,and y…I am using the general g code sender to execute the code… I am not able to cut geometry in easel since I am cutting terrain type geometry (Lots of “hills and valleys)”, for which I think easel is not able to generate passes…correct me if im wrong…

This sounds very much like electrical noise causing false triggers on the homing switches.

If this is the case there are some options for eliminating the noise. Try doing an “air” carve without the spindle running and see if you still have problems. If no problem with the spindle off then the spindle is the most likely cause of the noise.

You can use shielded wire for your homing switches, or place low pass filters on the homing switch wires close to the gShield.

You can use shielded wire for your spindle wiring.

@LarryM even it that’s the case, when I do homing the spindle is not on… That might be the issue during the cutting process… But doesn’t seem to explain z acting wiered during homing without the spindle on … Am I missing something ?

The spindle is not the only source of electrical interference. The stepper motor current is relatively high and is switched on and off rapidly even when the stepper motors are not turning so that also causes noise problems.

Shameless plug but this will stop all your (@NinaCackovic) electric noise issues with your limit switches and much more without rewiring your original wires. (2 instock) Ultimate X-carve Limit Switch Shield

New day, New Spindle (Dewalt611), cutting foam…Limit switches working fine… HOWEVER Z-axis still drops as it goes… Any ideas?!

There are three main causes for out of position errors. Either something is slipping (pulley loose on motor shaft, pulley loose on - M8 or ACME rod, Z axis belt loose), or something is binding (Delrin nut, V-wheels, bent M8 or ACME rod), or missing steps in the stepper motor.

The stepper motor can fail to step if electrical noise causes it to miss a step pulse command or if it experiences a load that is too much to move (mechanical binding of some sort or not enough current to provide the needed torque).

All of these things can interact to cause positioning errors. It can be difficult to located the exact cause.

Just start working through them one at a time and see if you can locate the problem.

After checking and double checking all the wheels and nuts, current in the motors and belting, I started to think there might be something going on with grbl and arduino. So as per intructions on the forum I’ve re flashed arduino using grbl from https://github.com/grbl/grbl.

So now when homing, machine sounds much better and triggers limit switches in much smoother fashion. However I had to invert direction port and homing for x and y ($3=3 and $23=3) since the machine now thinks its 0-0 is in the opposite corner. Not an issue, until I home the machine and it spits out that my machine 0-0 for x and y is at 31.2in
So I zero my work position and send the file. In mm it seems to work fine, but as soon as I use G20 to switch it to inches it starts acting crazy, moves along x axis and hits y rail, almost as the geometry was scaled or something…

First of all, I have no experience whatsoever with programing or arduino, so you will have to forgive stupid questions to follow…
I am completely lost with how one uploads a hex-file?! (hex uploader does not seem to signal wheather it was uploaded) After reading wiki pages and going through grbl resources I am still confused with how do I know what version of grbl have I flashed?

You can talk to grbl directly. You need one of the following: UGS, a terminal program such as HyperTerminal or Putty, the serial monitor in the Arduino IDE, Easel or maybe some other programs.

Whichever serial program you use you need to set the baud rate for the serial port to 115200 and also in the program if it requires you to set the baud rate.

Once you connect to the serial port that has the X-carve on it, grbl will identify itself with the version number.

[Edit] Just re-read your intro paragraph and saw that you use UGS. When you open the serial port grbl should display the version number in the console window.

I need some clarification on how to upload hex file. Hex uploader does not seem to do much… Does not spit up any message or signal that it has done something…