Xcarve losing machine Zero. Issues with homing

Check the set screws on the z-axis pulleys they can come loose and give the appearance of missing steps or dropping too deep as well.

It’s definitely not the bit slipping, since the collet starts hitting the material. And I have misspoken regarding my spindle.It is not Dewalt but standard 24V. I am currently running the machine at 7500rpm and 100 inch/m.

I understand zeroing systems ( machine zero, work zero…) I do not however understand how does a limit switch gets tripped without being touched, or how does a tripped switch fails to signal completion of homing, and as in my case , makes y axis to jump in one place after being pushed. Right now, whats happening ( this happens with Easel too) is that z axis moves upwards and without touching the switch, signals successful homing of z and then it moves to x,and y…I am using the general g code sender to execute the code… I am not able to cut geometry in easel since I am cutting terrain type geometry (Lots of “hills and valleys)”, for which I think easel is not able to generate passes…correct me if im wrong…

This sounds very much like electrical noise causing false triggers on the homing switches.

If this is the case there are some options for eliminating the noise. Try doing an “air” carve without the spindle running and see if you still have problems. If no problem with the spindle off then the spindle is the most likely cause of the noise.

You can use shielded wire for your homing switches, or place low pass filters on the homing switch wires close to the gShield.

You can use shielded wire for your spindle wiring.

@LarryM even it that’s the case, when I do homing the spindle is not on… That might be the issue during the cutting process… But doesn’t seem to explain z acting wiered during homing without the spindle on … Am I missing something ?

The spindle is not the only source of electrical interference. The stepper motor current is relatively high and is switched on and off rapidly even when the stepper motors are not turning so that also causes noise problems.

Shameless plug but this will stop all your (@NinaCackovic) electric noise issues with your limit switches and much more without rewiring your original wires. (2 instock) Ultimate X-carve Limit Switch Shield

New day, New Spindle (Dewalt611), cutting foam…Limit switches working fine… HOWEVER Z-axis still drops as it goes… Any ideas?!

There are three main causes for out of position errors. Either something is slipping (pulley loose on motor shaft, pulley loose on - M8 or ACME rod, Z axis belt loose), or something is binding (Delrin nut, V-wheels, bent M8 or ACME rod), or missing steps in the stepper motor.

The stepper motor can fail to step if electrical noise causes it to miss a step pulse command or if it experiences a load that is too much to move (mechanical binding of some sort or not enough current to provide the needed torque).

All of these things can interact to cause positioning errors. It can be difficult to located the exact cause.

Just start working through them one at a time and see if you can locate the problem.

After checking and double checking all the wheels and nuts, current in the motors and belting, I started to think there might be something going on with grbl and arduino. So as per intructions on the forum I’ve re flashed arduino using grbl from https://github.com/grbl/grbl.

So now when homing, machine sounds much better and triggers limit switches in much smoother fashion. However I had to invert direction port and homing for x and y ($3=3 and $23=3) since the machine now thinks its 0-0 is in the opposite corner. Not an issue, until I home the machine and it spits out that my machine 0-0 for x and y is at 31.2in
So I zero my work position and send the file. In mm it seems to work fine, but as soon as I use G20 to switch it to inches it starts acting crazy, moves along x axis and hits y rail, almost as the geometry was scaled or something…

First of all, I have no experience whatsoever with programing or arduino, so you will have to forgive stupid questions to follow…
I am completely lost with how one uploads a hex-file?! (hex uploader does not seem to signal wheather it was uploaded) After reading wiki pages and going through grbl resources I am still confused with how do I know what version of grbl have I flashed?

You can talk to grbl directly. You need one of the following: UGS, a terminal program such as HyperTerminal or Putty, the serial monitor in the Arduino IDE, Easel or maybe some other programs.

Whichever serial program you use you need to set the baud rate for the serial port to 115200 and also in the program if it requires you to set the baud rate.

Once you connect to the serial port that has the X-carve on it, grbl will identify itself with the version number.

[Edit] Just re-read your intro paragraph and saw that you use UGS. When you open the serial port grbl should display the version number in the console window.

I need some clarification on how to upload hex file. Hex uploader does not seem to do much… Does not spit up any message or signal that it has done something…

When I tried to load the .hex file from the Inventables web site, it didn’t work.

I downloaded the source files, re-compiled and then loaded in version 0.9j. It worked fine.

The source code is here: https://github.com/inventables/grbl

Instructions for compiling grbl: https://github.com/grbl/grbl/wiki/Compiling-Grbl

I assume hex file has .hex extension? I have followed all the steps for flashing grbl…Using Arduino IDE method…By doing this hex file is not created?!
Then if I follow compile for Mac OSX I get stuck on this part

To compile: Once your paths are setup, all you will need to do is go to your grbl directory and type make. (To clear all of the old compilation files from a previous build, type make clean first.) This should call avr-gcc, begin compiling grbl, and create a brand new firmware file called grbl.hex that may then be flashed to your Arduino."

Grbl Directory? And where am I typing “make” command? . I see a file in grbl-master folder that says “make” but when i run it, terminal spits out lines and lines of messages looking like this

/Users/nataliehuguet/Desktop/grbl-master/Makefile: line 96: cpp:: command not found
/Users/nataliehuguet/Desktop/grbl-master/Makefile: line 97: COMPILE: command not found

Also turns out I do have grbl v0.9j… Would you suggest using v0.9i instead? Thanks @LarryM !

When you use the Arduino IDE (the easiest method) you don’t create a .hex file.

You set up the grbl library and then open the File->Examples->grbl->grblUpload sketch. Once this is loaded you press the Upload button (right arrow) on the IDE toolbar.

This compiles the code and then loads it into the Arduino.

Be sure to select Tools->board->Arduino Uno and the Tools->Port->COM1(substitute your COM port number) before you do the compile and upload.

Also, select 115200 for your baud rate on the COM port that the Arduino is attached to.

v0.9j versus v0.9i? I still have issues with cutting geometry in inches and setting my machine 0 in the bottom left corner. After homing it still notes it at -31.something inches.

v0.9j supports M30 v0.9i does not. I use M30 in my post processor code for V-carve Pro.

I had trouble with the negative co-ordinates. Something I did fixed it. I don’t know what it was. It might have been v0.9j, just not sure.

You could try v0.9j to see if it would help. There were some other changes besides the M30 support.

I’ve tried re-flashing both v0.9j and 0.9i using using IDE…Now it wont home at all… it moves down maybe 1/4" and triggers the “alarm”…
I got this thing in June and I still haven’t managed to cut a thing on it…

Go into UGS to the Command tab and enter $$

This is a grbl command to have it print out the grbl parameters. Then post them here.

I have adjusted all of those. From turning on homing and limit switches, to reversing x and y axis travel direction. I started dreaming about grbl parameters… I can post them, but I am certain it’s not that

Do you have the standard kit wiring for the homing switches or did you change over to shielded wire?

Would like to see the parameters anyway. Some thing is wrong and we need a good place to start.