XCarve Touch Plate Not Working

I have the older Arduino and gShield combo and have an issue with my touch plate all of a sudden. It will not work at all and I have tried different software. I also eliminated my touch plate from the mix and made a closed loop to see if it would be detected by Easel or PicSender. None of them even can tell the plate is attached. It’s showing open when my $6=1 and closed when $6=0. I tried to check voltage coming from the #5 port on the Arduino and I get nothing. Any thoughts or is this thing dead? I looked and an Arduino Uno Rev 3 is only $23 but hate to spend money if that is not the issue.

I’m not quite sure what voltage I should be getting and if there is any other testing I can do to check the board.

Thanks for all your help on this!

With #6=0, A5 should measure 5v compared to ground.

Hey Neil- so most times I don’t get any voltage coming from that line. One time I did get some and it was poor .032 - not even 1 volt. Could that Arduino have an issue?

That’s with nothing connected?
Sounds like it might.

If you feel comfortable doing it, you could change the CPU_MAP so that you’re using a different pin. You’d have to recompile grbl to do that.

Any good articles or videos on doing it? I’m a computer programmer so I should be able to figure out. Hopefully…otherwise it’s a new Arduino.

I don’t know, but there’s nothing to it if you can reflash the arduino.
I’d recommend you use the Arduino IDE to reflash it.

Get the repository from here.
In any text editor, open “cpu_map.h”.
You’ll just want to change a couple values in this section.
For example, if you’re not using Mist Coolant, you could change:
#define PROBE_BIT 5 // Uno Analog Pin 5
#define PROBE_BIT 4 // Uno Analog Pin 4


#define COOLANT_MIST_BIT 4 // Uno Analog Pin 4
#define COOLANT_MIST_BIT 5 // Uno Analog Pin 5

Save, compile, and upload to the Arduino.

Note: That will give you the most recent version of grbl. If you want a different version for some reason, check the releases page for the source.

1 Like

Neil - I can’t thank you enough!!! I was able to flash it and all is working now on Pin 4 for my probe. I really do appreciate it and thank you!!! Have a good one and stay safe.