Xcarve with Chilipeppr Error: Alarm Lock


i don’t know if this is the right place.to post this, but here goes :smile:

I have made my xcarve work with easel, no problem however when i moved to chilipeppr, i get the Error: alarm lock, and nothing much happens. I have seen references to that i need to do something before connecting to the xcarve from chillipeppr. However i have not found anything in the gui. here is a picture of my interface
Google Photos


If you are using Ardunio board I think you need the GRBL version of Chilippr


Use this link for the grbl/arduino X-Carve.

1 Like

thank you,

this helped a lot :smile:

1 Like


I seem to have issue with “resetting” the home position. Im unsure how i tell the grbl to use the current position as the start point. The process is unclear to me.
Basically i “jog” the head to where i want it to start, but it just wanders off and drills a hole ruining a bit, when i start the job.


Go to where you want your zero to be and upper right on chilipeppr you can “zero out” all axis at once or hit the down arrow next to each one and do them one at a time.

Thank you Erik,

that was just the piece of information i needed :smile:

1 Like

If you have homing enabled, the machine by default starts in lock mode until you home, you can just send $X or disable homing if you’re not using it.