Inventables Community Forum

XCarve won't connect to controller

My XCarve won’t connect to the controller. I recently installed Estlcam and I think it changed GCode. I can’t even connect to change back. Any ideas?

Did you pull up on the emergency stop button? Gcode shouldn’t make a difference in connecting up.

Yes. Also reinstalled driver. Also have Lightburn for JTech laser and that doesnt connect either. Any ideas/help I can get would be greatly appreciated.

Mo

Blockquote

check to make sure the com port is right and also the baud rate.

I did reload the FTDI

driver. I will try hooking the cable directly to the Xcontroller and post an update.

Cable hooked up direct to boards. Still no luck

Try downloading the stable version of UGS. It won’t require Easel. It is a simple controller with fewer bells and whistles. You probably will still want the highest baud rate and have to find the com port. It requires at least Java 7.0 I use version1.0.9. on my laptop. I don’t think it would hurt to try it.

I would also check the usb cable between the computer and the xcontroller.

I replied via the email you sent, but im not sure if you got it. The cable is brand new. Where do I get the stable version and what grbl-9-1is the best way to install it? I tried Xloader to load a file I found via the forum (XCarve_JTech_grbl-9-1_2017.hex)_. It said loading and never got past that point on the first attempt. All subsequent tests say “Can’t open port”. I uninstalled and reinstalled the easel driver. I also installed the FTDI driver package. I have attached a copy of my device man

ager

https://winder.github.io/ugs_website/download/

1.0.9 Classic is the one I use. Simple and it works.

I’m no computer genius, but I managed to get mine working on multiple installs. My laptop will come up with only 2 com ports and it only worked on one of them. As far as the baud rate, it is the 115200 one on mine. Java 7 or higher needs to be installed first.

I was using 2.0 so I’ll install 1.9 Classic. I already have Java installed. Will let you know if it worked. Leaving in a few but I’ll do it when I get home (otherwise I’ll be stressing about it and won’t sleep :unamused:). Hopefully I will send a follow up that it worked.

@MaureenCnota Do you hear the chime when you plug in the USB cable? Have you restarted everything?

Yes, I hear a chime when I connect to a USB port and and a chime when I disconnect. I have started and restarted the computer many, many times. I’ve uninstalled/reinstalled Easel driver, Lightburn and Estlcam. I’m new the g-code world so I’m sure it will be an easy fix, but I don’t have a clue on what else I can do.

P.s. I tried installing UGS Classic as instructed but, even though I verified I had it installed, I get an error stating it needs Java

did you overwrite your controller software with Estlcam? it has been several years since I have used it but when I did it re-flashed the controller with there own software and I had to flash the controller back to stock to get it to work with GRBL again.

here is an old thread on the subject and how estlcam uses there own control software.

I read the extremely long post which you referenced. It basically said I needed to reflash my GRBL. My question is, how I do that? Thank you

the easiest way at this point would be to use the Estlcam software and connect, then re-flash from inside that. it should have a restore to original firmware.

open Estlcam and on the menu on top it should have a setup drop down menu, click on that, then it should have a cnc controller setup menu, click on that and a new window will pop up. on the right middle of the new window there should be a “restore previous firmware” or something similar. click that and it should rewrite your Arduino chip (controller) to the original GRBL.

should that fail then you can find an old version of GRBL here http://cdn1.inventables.com/hexfiles/grbl/inventables_grbl_09j_2015_07_17.hex

follow the instructions on installing this and then it should get you where you can connect and then upgrade to the newest version.

I had this problem, even though I have 64bit Windows Java apparently installs 32bit if you do it automatically. If you have 64bit UGS installed make sure you install 64bit Java or else use the 32bit UGS. That should get UGS running, at least.

Thank you gentleman. I will try to reflash GRBL with the file provided

Maureen

Let us know if you have success. Just want to make sure it worked out okay.

Kenneth,

The hex file you provided will not open in UGS and if I copy the link, it gives me a " This site can’t be reached" error. any thoughts?