XController and Estlcam

Have been able to get the XController to work with the XCarve (axis movement) however I cannot get it turn the DeWalt on and/or off by using the PWM output. The spindle responds fine with code made/sent from Easel but the Estlcam code will not activate it. I did notice that the commands made in Estlcam (M03 and M05) are not compatible with Easel and I usually change them (M3-M5) with no issues. However, this doesn’t work (code changes but spindle does not respond) with Estlcam.

Any thoughts?


do you use GRBL to control the machine or Estlcam?

If you use GRBL please send me a working Easel example and I’ll update the preset in Estlcam accordingly.

If you use Estlcam to control the machine try this:

  • Set lower RPM limit to 0
  • And upper RPM limit to 1

  • Estlcam controls the PWM output with the “S” word (rpm) + enables and disables it with M3 / M5.
  • If the value of the S word is lower than the upper rpm limit the PWM signal has gaps and will be unsuitable for switching applications.
  • By changing upper rpm to 1 you basically make sure any rpm will result in a clean “on” signal on the PWM output.
1 Like

Thank you for the quick advice! I’m running an extended project with Easel right now but will try your suggestion tomorrow. My current settings for the min and max speed are comparable to the speeds on my DeWalt (16000-22000). I’ll make the change and post the results.

On a separate note: is it required to program the Arduino each time you use Estlcam? Mine doesn’t seem to connect without loading up my saved settings and flashing the Arduino.

Reprogramming the Arduino is definitely not normal. Something is wrong.

This can happen e.g. if you start Estlcam before connecting the machine to the computer.
Your machine needs to be ready before starting Estlcam.

I’ll do some testing and again, will post my results!

Changed the max/min speed settings to “0” and “1” and it works perfectly. Also able to connect straight to the machine without having to re-flash every time.

Works as advertised!!!

Can you post what setting’s you used in Estlcam to program the x-controller?

Thanks, Patrick.

Absolutely. Remember that you still need to calibrate and adjust your step distance. I also have the X and Y axis reversed. There is a check box in the setup that you can select to accommodate this.

You’re going to find (at least I did) this controller gives you most flexibility with all the bells and whistles. I wish it would do a little more (accommodate Charlie’s automatic zeroing) but for the price you can’t beat the product.