XController Homing-SOLVED

Have had the XController since it came out. Used homing from the beginning without issue. Attempted to home and my Y switch shows triggered even though it’s nowhere near the home position. I have reloaded the grbl hex (1.1f and 1.0c (Larry’s version)) but the switch shows triggered. While troubleshooting I have changed switches and also switched from NO to NC; no happy. I have even disconnected the switch from the XController (at the box) but the triggered status is still there, I can deactivate the homing in grbl and move the axis’ without problem. Only issue is with the Y axis. My thought is something on the board inside the XController. Something I’m missing?

If it shows triggered with nothing connected then it is a problem with the X-controller.

Try removing and re-seating the bulkhead cable(s) for the homing switches.

Yeah, I haven’t torn the box apart yet but it’s looking like I won’t be able to get away without doing so.

Well, I’m stumped. I tore down the XController back to it’s basic parts. Inspected the boards and could not find any obvious signs of failure. All the tracings looked good but I’m not an electrician. If it isn’t obvious I wouldn’t know what I was looking at. Put it all back together again, hooked it up without the Y homing switch plugged in but I’m still getting the triggered notification. Guess I’ll contact the team and see if there’s something I can swap out to get back up and running.

There are very few things to go wrong with the homing switch interface, but if one of them is bad it doesn’t work. There are a couple of things you could fix, but they are not likely to be the problem. Most likely the 328P port is bad.

I suspect that you need a new processor board.


If you want to verify, disconnect the ribbon cable from the power supply board to the main board. If it still shows triggered, it’s internal to the main board. If it’s open/not triggered it’s either the ribbon or the power supply board.

The ribbon between the two boards are just the digital I/O pins.

1 Like

Disconnected the ribbon cable and the switch still shows triggered. I guess that narrows down where the fault lies. Thanks for the help!

I had an issue similar but it was noise. Did you rule out noise?
I had to insulate my limit switch wires and use a cap to filter out the motor noise.
Not sure why you would have to as a stock system shouldn’t be an issue.

Xcontroller has integrated caps for noise filtering, one of many pluses for it.

ahh I move away from stock so I only had the original controller before.
I was not aware of the caps there.
Are the wires shielded?

How can I figure out if my switch is showing triggered? I just assembled my x-controller and am trying to troubleshoot a similar issue.

Props to the Inventables team once again. My Xcontroller was purchased during the original pre-sale and has seen me change the DeWalt brushes numerous times. I contacted them about my issue and asked about getting a new board. Having the hours on the machine that I do I felt it proper to purchase a new board and not expect any freebies. My new board showed up overnight and didn’t cost me a cent. Plugged it in and am back in service. THIS is why I haven’t gone to a new machine. I’ve very few original parts still used on my machine but I’ll keep with it based on the service alone. Nice job kids! This issue can be marked as “Solved”.