XController worked one night, now doesn't

One of my students got the mechanical and electrical components assembled last night. We hooked up XController and were able to move X and Y easily and in the correct direction. The Z axis was more difficult and resulted in a stalled motor, and eventually a broken belt (150-2Gt) (we nicked it trying to help it move). We greased the screw better and were able to make it move with a 200-2gt and a fashioned belt tightener.

We thought we were good to go and went home for the night. Came back this AM to finish and make first cuts, but when we turned on power and lifted the Estop buttons, the motors whined much louder than last night - motors seemed like they wanted to move, but were stalled and still trying to move. AND Power LED pulsed a bit with the whine. AND the device would not be recognized by either computer that ran it last night. It shows up as “unknown device” and computer gives NO “dahdoing” when XController is plugged in or unplugged. We have restarted computer, uninstalled “unknown device”, rescanned, but to no avail. We tried two stand alone arduinos - a mega and an Adafruit Feather ESP8266, since we had ARDUINO IDE installed and working before - and working with Arduinos. And again, it worked last night, but tonight, there is NO recognition of the XController board. We need help fast, as we have a backlog of parts to cut.
I have a Gecko 540 on a micromill, maybe I should replace your controller?? Then we could use Mach3, which is what I use on a couple machines now.

thanks in advance!!

Hi @ChuckMerja - if you are still having issues, please reach out to our Customer Success team!