Xcontrolller not connecting to computer

I turn on the x controller and I cannot get past the confirm settings window. I have downloaded the updated driver that is calls for when the x controller cannot connect to the computer. Please help.

First thing to check it to make sure your E-Stop button is fully up. If it is, then recheck all wiring connections. Some might look like they are seated but might not be. One other possibility is to check the wire connections to the E-Stop button. There were a few X-controllers with bad connectors.

1 Like

E-STOP BABY, that was it. Thanks a lot. I was thinking that the E-Stop was supposed to reset by itself. Obviously it does not. hahahaha… Anyway,when I was testing the limiting switches I found out I put one in the wrong place. I just have to fix that and continue setting up. I will do that when I get home after work.

Again, thank you very much.

Glad that it was a simple fix. Happy carving!

okay, another question. Now that I have it all set up. To use the VCarve pro, do I need to have the USB stick plugged in or was it just to download the software. Reason I am asking is because my laptop only has one USB port so I need to have the XController hookedup to it. I don’t have another port for the USB stick to be connected to the computer at the same time as the XController is connected.

If your software is installed on the same computer that you intend to connect with your X-Carve (X-Controller) you will only need to have the X-Controller plugged into the USB port. Just generate the gcode via VCarve and save it to a local directory. All you would need to do is import from that directory.

As a side note, I found that I have a better connection to my X-Controller through a powered USB hub. The additional benefit you would gain is an extra USB port if you found yourself in a situation that required both. Not needed, but only a personal suggestion.

1 Like

Michael, I am having the same error message as Jesus, and the problem is not my stop button. Any other ideas why this might be happening?

I’m not sure if you meant you’ve confirmed the wiring to the connector is good so I will start there. Some might think just making sure the button is up is enough; For some it is. Other users reported having bad connectors. Remember (caution) you are working with powered mains. Safety first.

If you have confirmed your connectors are good. Check the other connections on the back side (not the terminals, but the board connections). Again, a partially seated connector has been the source of problems for other users because it was not fully seated.

I should have asked, is this with the X-Controller?

Does the power light come on? Have you ever had a connection before? Anything change?

More information please.

I had the same problem and it turned out I had to jiggle the estop button a little after raising it.

I just finished to assembly my brand new x-carve and having the same issue. I’m not able to connect to my Mac (running MacOS mojave). I’ve tried to connect to another mac with an older MacOS and still not working.

More information, the light is green on both panels, I’ve checked the motors when I turn the x-controller on they lock in position, so they are working… I also have tried a different USB cable and connect thru the USB port on the mainboard.

Hey TomTosti, did you find the solution?

Hi @NemoSampaio - if you haven’t already, reach out to our Customer Success team. Here’s their info: https://inventables.desk.com/

Thanks Jessie, I’ve sent an email to the support with my order number, but did receive the reply yet.