Y Axis Fried?

The white cable came loose from the terminal block under the left y axis stepper motor. I went to run a job and the Y axis kinda tried to move a little and then wouldn’t move anymore. So I shut down the controller and did some inspection. That is when I noticed the disconnected wire. I reconnected the wire and power the unit back on. The Y still doesn’t work. X and Z work fine. I can see on the board the X and Z lights light up but not the Y. I did further troubleshooting by disconnecting the X and the Y from the board and I put the wires for the Y axis motors in the X slot. With the Y axis connected to the X spot on the gShield the Y axis works fine. Further testing, I put the X cables in the Y spot on the gShield and the X wouldn’t move. Not surprising since the light never comes on. It does come on briefly when I push the Y axis. I also tried: unplugging the unit for a while and plugging it back in, disconnecting the usb, restarting the computer, using a different usb.

So I assumed a fried a board, what I don’t know is if it’s the g shield or the Arduino.


Most likely GShield. The 24v circuit that the steppers run on is mostly isolated from the 5v signals sent by the Arduino.

I would suspect that you just fried the Y axis stepper driver. It’s not uncommon.

Thanks a lot for your response Brad. I’ll likely be purchasing a replacement GShield tonight.

You might try simply buying a few new DRV8818 and replacing it on the board. That’s a $3 fix instead of $50.

IF he is capable of surface mount work that is. GrillShield is all SMD’s

Yeah, true. The DRV8818 is a TSSOP though, so it’s pretty easy to solder. The pins on the bad chip can be cut with an Xacto knife and individually removed (heat gun for the package since it has a thermal pad). For the new part, just glob solder all over the pins then wick away the excess with some copper braid (then heat gun again to get the thermal pad connected).

I suppose they have already ordered a replacement, so they may as well try the fix on the old one instead of tossing it, it’s nice to have a spare.

Thank you all for your responses. I ordered a new gShield, replaced the old one and everything is working fine now. I’m not an electrical engineer and although I have a solder gun I’m not very good with it. However, my brother-in-law is an electrical engineer. He builds robots and what not so I’m sure he is capable of swapping out the DRV8818. I’ll have him fix it and that way I will have a spare for when I fry this one. Just kidding, I hope.

Sorry if I am hijacking this thread, but I seem to have the same issue as the OP, except its the Z-Axis. Ive confirmed that it is not the motor and the shield is properly seated. Does anyone know where I can find a Drv8818? Ebay has them for less than $5, but a month for shipping. There is one in the US, but they want $22 for it. I have yet to get the thing completely up and running, so I am assuming the board was defective. Ive emailed Inventables to see if they will replace it, but if they wont I would like to attempt to repair this board rather than shell out $60 for a new one. Thanks!