Y axis Homing Problems

I’m brand new to CNC and picked up an XCarve from Craigslist. It’s a bit of a strange duck, 500x750mm. Has the ACME rod so I assume it’s post 2016 model. Has GRBL 1.09c for firmware.

So, I’m having a couple issues. First, when I home the machine Z homes fine, X homes fine. But Y doesn’t jog back far enough to release switch. I literally give it a nudge and the switch clicks off.

So this is a bit of a pain. I can make it work with UGS and get a reliable home position with a nudge. But Easel will not home under any circumstance. So this leads me to homing machine in UGS and then going to Easel.

Other thing I’m struggling with is the probe. It doesn’t have the jack on it but has 2 wires from the controller that I hook alligator clips to and then use a bit of PCB for a plate. When I go through the probe sequence it won’t recognize the probe is plugged in until I touch the plate to the bit with the clips hooked up. At which point I can go thru to he start probe bit but it shows the probe is in contact with the plate when it’s not.

Any and all help is appreciated for a newbie.


What do the limit switches make contact with when homing?

Change GRBL parameter $27 from 1 to 3 (pull-off distance in mm)
Open Easel, press CTRL+SHIFT+D to open Machine Inspector and in the Console window type $27=3 and press Enter
Reboot controller, retry homing.

This did the trick… homing works now… just have to sort out the probe issue. I can use probe successfully in UGS but not in Easel. It won’t let me get past ‘Plug into Carriage’ unless I touch the plate to the bit with clips attached. It then goes to an ‘In Contact’ state when plate and bit and plate aren’t touching… any thoughts?


I dont have the probe so dont have experience with that :frowning:

Regarding homing sequence, Z will be tapped twice first, then X/Y will follow in unison. If for some reason Z fail to tap twice (for instance lacking pull-off distance ($27) to properly clear the switch the controller will throw an alarm.

my machine does not complete the homing sequence. Have gone into the homing sequence and this is what it shows, is that correct? when I click on the homing sequence it shows lots of alarms. Z-motor goes up to max position and stops there, has to interrupt homing sequence as it only chops in max position.

First of all, establish that the switches work.

  • Reset machine, get it connected and open Machine Inspector
  • By hand, press each homing switch, do the X/Y/Z rings in the MachineInspector turn green?

If yes, change $27=5
If no, troubleshoot switch wiring untill “yes” :slight_smile:

1 Like