Y-axis homing switch not touching anything/triggering

I’m having issues with my y-axis homing switch and feel the orientation may be incorrect. I currently have the homing switch oriented with the hinge on top - which seems like the way the instructions have it oriented - but this means that the switch isn’t hitting anything when at the bottom left corner of the board. After testing it with the Easel homing sequence test, the machine doesn’t not stop, and you can see that the home switch trigger isn’t being pushed up against anything.

If I flip the homing switch around - hinge on the bottom and writing on the inside - the image no longer matches the instructions.

Am I missing something? Any help would be greatly appreciated - this is driving me nuts!

The switch should be touching this bolt to trigger it. Adjust as needed to get it to stop were you want it to. Steve

1 Like

Here is a view of the X-Axis endplate with the limit switch attached.



Brandon Parker

1 Like

The switch lever hits an aluminum spacer that is connected to a bolt. It has to be far enough away from the end of the belt to hit it and move back the set amount of distance in the Grbl settings. I actually had to use a longer spacer on mine to make it have good contact. Luckily I had extra parts here from my shapeoko 2 experience. You may have it too close to the end of the belt. Try moving it back an inch and try again. You can always adjust the spacer/bolt back closer if you find this is the problem.


I’m constantly searching on the internet for posts that will help me. Too much is clearly to learn about this. I believe you created good quality items in functions also. Keep working, congrats!