Y Axis issues

I received my XCarve a little over a week ago. I finally got it put together and wired up. I followed the instructions to the letter, made all my adjustments and wired everything up with great care. I’m no stranger to assembling machines and wiring up devices like this, I’ve been doing stuff like this for over 20 years, with this being my first CNC.

When testing the axes upon machine configuration, X, and Z worked as expected, but there was nothing from Y. I unplugged power and moved the Y axis by hand and there was light on the LED of the GShield when doing so. I check all my wiring again and tried again. Same thing, doesn’t work. So I did some process of elimination, I hooked my Y axis cable to the X axis controller of the GShield and the X axis cable to the Y axis controller and tested it again. The Y axis now worked when sending X axis codes, but nothing from the Y controller. I flashed the Arduino with the latest GRBL revision available on Inventables’ github.

Still no dice. When I have power going to all the axes, the Y axis provides a lot of resistance if you try to move it by hand. If I lower the Y axis potentiometer on the GShield all the way the motors on the Y axis stutter a bit.

I think there’s an issue with the Y axis GShield controller. Of course it has to be Saturday and Inventables is closed, leaving me unable to do anything.

Anyone have any suggestions?

Thanks in advance.

If u have experience with electronics then test the power out from the the board.
Mayby raise the pot not lower it?
And less helpfully mayb get the x-contoller… after i upgraded i had zero electrical issues.


This is a classic test and the results confirm that you have a bad Y axis driver chip. Call Inventables for a gShield replacement,

I checked the power out. Each motor is getting 24.4 volts DC.

Y has 2 motors did you swap 1 pair to reverse it?

Yes, the motors run in the right direction to move the gantry when being used on another axis controller.

very strange. what else can u do to test?

I tried various versions of GRBL software on the Arduino from the GRBL github site as well as the XCarve site. With the updated software version, when I issue a Y command the motors on both X and Y just twitch once. I went back to the XCarve GRBL .9i software and it just twitches the Y and X axis when issuing Y axis commands. X and Z still work fine.

Motors are fine.

And check for damaged or bent pins

Yep, I’ll get a small stutter once on the Y axis.

I’ve pulled and reseated the gshield from the Arduino a few times. I’ve even tried using one of my Arduino Uno boards with the flashed grbl software.

It might be the IC controller chip that sends the microstepping sine wave to cause the motor to spin. Power at the terminal lugs wouldn’t dictate movement without controlling the changes in the winding activation. Stepper motors are brushless, power alone won’t make them work. I wish I knew how to test the chip.

You have already tested the chip. When you swapped the x and y axis, the y axis worked with x axis commands.

The gShield is defective.

Turns out, both the Gshield and Arduino had issues. I’m guessing that the Gshield had an issue, when powering it up it fried a digital out pin on the Arduino. Inventables sent me a new Gshield first, then I got it and it still didn’t work. Called them, they sent a new Arduino. Got it today, installed it. Everything works great. I’ll upgrade the xcarve soon to the new version and will get the x controller.

1 Like

Glad you got it going.