Y Axis mirrored. Tried $2=2 in GRBL, nothing changed

I was doing a test today and discovered that my Y Axis was mirrored. I tried updating the GRBL using $2=2 (which is supposed to mirror only the Y Axis). It was $2=0 so this seemed like the logical thing to do. Tried making an “air” cut and noticed that it was still heading in the wrong direction. I adjusted (not enough) my zero and gave it a go. Other than it being reversed and not zeroed correctly, I think it’s a success. I’ve attached a screen shot of my GRBL file.Is there something I’m missing? BTW, using CNCjs on a Raspberry Pi 4 and if I can get the last few wrinkles out I think I’m going to be busy making lots of saw dust and plexiglass chips.

Thanks in advance,

1 Like

Here is a picture of the first cut. It’s a bit too small for a 1/8" bit, but it’s just a scrap.

Hi JH, you’re going to want to change $2 back as it was and instead Change $3 which is the direction control.

Since $3 current setting is 1 and you want to invert the Y, then the correct setting is $3=3

Thanks, will give it a try this morning.

1 Like