Y-axis moves in the wrong direction when homing

Folks, I have just completed my tool build and am trying to get through the Machine Setup. I have gotten to the homing set in Easel but have run into a problem. My Y-axis moves in the wrong direction. The other two home just fine but not the Y. I go through the troubleshooting when I indicate a problem with axis motion and it says it will change the Grbl settings but the Y-axis keeps moving to the back of the tool to home and the limit switch is at the front. Can anybody give me some help?

Go to the Machine Inspector and get the grbl parameters and post them here.

I am having PRECISELY the same problem. What was the answer?

@PierreLugosch

1 Like

I had the same problem and had to change the homing settings in grbl. In particular I changed $23… If you go to the following link you should be able to find what settings you need to change based on your needs. If it’s just your Y-axis that needs inverting, based on the grbl invert mask table your $23 should be changed to 2 ($23=2) https://github.com/grbl/grbl/wiki/Configuring-Grbl-v0.9

1 Like