Y-axis not synchronized

Had a strange problem. I did the exact same thing as @PhillipLunsford and did my roughing on a foam job with a 1/8” instead of the 1/4” that I specified in my CAM… sigh, ok, so I aborted the job during the second pass of roughing (I figure a 1/4” redo will get rid of the silly vertical slots left by the narrow end-mill.]; plus it’s pink foam, so not like the mill is going to “crash” into unexpected material with any risk to the machine. However, when I switched collets I of course bumped the x-axis so went to re-home and reprove before restarting the job from the beginning. The machine stopped maybe 6” in y before the end-stops like it was mechanically hitting something (the rails seem clear to me).

I then jogged it past that point, which it weirdly got past, but was moving particularly jerkily. I also noticed the right y-axis was lagging the left, well depending whether I am going positive or negative the lag switches sides? [see video below]. I hit reset on the cncjs console as the machine was clearly unhappy when it stopped again. So after I reset, I was able to easily move the y-axis + (up the rails) no problem by hand without any obstruction a good 12+ inches [towards end of video] - note I do not have the steppers set to always holding mode. I then hand brought it back to the front, and jogged 10” positive in y and again it made it, but I still can’t home. The steppers are the original stock Nema23 (haven’t gotten around to the replacement 269oz steppers which you might see in the video sitting at the top right - still waiting on the 9mm belts and pulley set), I mean I guess it could be the stepper driver voltage setting (a smidge weird after years to suddenly on a random Thursday evening have this issue).

Happy to adjust the stepper voltage if folks think that’s a good start (guess it’s unlikely to be harmful). Could this just have been a thermal issue? I don’t think if I recall the steppers have heat sinks? I don’t think this is the problem since it’s doing it now after being off all night (I assume the steppers are close to room temperature in the basement which is 68F) when i went to film the video.

@NeilFerreri1, you’re always good for a solution…

1 Like

First thought would be a wire disconnected (or broke) on the lagging stepper.
Second thought would a pulley that came loose (check set screws).

2 Likes

You are my hero! 2 set screws were gone; everyone laughed when I bought the assortment of grub screws… who’s laughing now?

2 Likes

Although since I have the model where the pulleys are glued on in some way, not sure what the set screws do since I can’t remove the pulleys…

So the problem is still there?

Nope you fixed it!

I was hoping for something more interesting than set screws. :wink:

1 Like

I wasn’t, since I had to get a job out!

1 Like

Well it recurred. so first I retightened all the grub screws without success, so decided to check the wires and lo and behold the green wire for the left side Y stepper had a loose screw on the barrier strip and was making intermittent contact. NOW it seems to be working perfectly. (Oh god, it’s 2020 and I said that out loud!!!)

3 Likes

Haha spoke too quickly. Suddenly I couldn’t home the x-axis. Yep, found the grub screw had fallen out. Put it back in with some blue thread-locker and everything worked perfectly. So I took every screw out and put thread-locker on everyone and snugged them down.