Y-Axis Not Working, Lesson Learned

I just wanted to share my issue that I had and how I fixed it. It was a very stupid mistake that I wanted to point out in case anyone else is having the same issue. My issue was that during machine setup when I would click the arrows to move the Y-Axis it would just barely jerk but not actually move. X and Z were working fine. I went through all the troubleshooting I could find. First I “checked” the wiring by making sure everything looked right and wasn’t loose. Then I adjusted my belts and V wheels, even tried taking the belts off and loosening the V wheels all the way to make sure and even under no tension the Y-Axis would just twitch. I tried switching the X and Y cables in the G shield and the X-Axis still worked in the Y-Axis spot but the Y didn’t work in the X-Axis so I knew it was either the wires or the motors. I finally decided to just start undoing the wiring. I started with the left Y-Axis motor since neither motor was working properly so I figured that was where the issue might be. I undid the wires and found my mistake. When everything was wired up it LOOKED correct but then when I pulled them off I could see that I had mixed some wires. Specifically step 4 under Wiring where you wire the right motor to the left. You are supposed to switch a couple wires so the motors move the same way, red with white and red with blue. This is where my problem was, not that I didn’t switch the colors, I did. But, like an idiot, I somehow did red/blue of the left motor and red/white of the wire coming from the right motor so I was basically looping them through themselves instead of through each other. I think this happened because all the wires were close together and I wasn’t paying close enough attention when I grabbed the red wire I needed. I figured this might help someone even though it makes me look dumb.

That’s funny because I’ve constructed many CNC machines and stepper driven machines and made THE SAME EXACT MISTAKE when I built my x-carve. I was supremely confident in my wiring job. I did not trace my error down but when I connect the two motors together at the terminals, the wires have to be wired the same way to get it working properly (which means I switched the wires on one of the steppers at the stepper motor). Shrug it off, move one to the next inevitable mistake.

Yeah, (un)crossed wires on the Y motors issue usually present as “Y axis twitches but doesn’t move”, good catch working through the problem and getting it sorted!

Been there did that.

dont feel like you are the only one…you’re not.

I almost made a mistake at that same spot last night. Something clicked in my tired brain, fortunately, and I caught it before I miswired it. Glad you got it sorted.

So any help would be great. I thought I had the same issue. Everything sounded identical in my problem but when I took the wires apart, I am 95% sure they are correct. Then I switched them just for good measure and nothing. Where else could the issue be with the gears kind of grinding and not going anywheres?


Double check your connections to the gshield. you may also need to bump up your y axis pot a notch as well.

ok, I’ll go check those connections but I’ll have to look up the y axis pot. Not sure what that is.

small, off-white box with a dial on the shield, 3 in all near each wiring connector that has what looks like a phillips screw on it.

It’s quite delicate and only has about 270 (?) degrees rotation on it. use a precision screwdriver to turn it just a few degrees clockwise, say from 12:00 to 1:00 for example.

Ok, read up on it a bit and saw where Zach linked to more info. I’ll check connections first and report back.

Thanks @JkWestphal. Hopefully I can get up and running this weekend

Well, I guess I’ll just come out and say it… I’m a dummy. So I take off the fan and there she is. The red Y axis wire, just hanging out, doing its own thing. I swore it was in when I did the wiring check. Thanks for the help! I’m up and running!

1 Like

Been there. done that. :smirk:

I’m still trying to figure this out unsuccessfully. I also found the Y limit plug probe but can’t figure out or find where it gets plugged in. And in the midst of this I broke a limit switch… I will never get this thing running. Do they have a traveling repairman?

@EricaStrausbaugh if you start a thread with the issues you have, you’ll get help. I don’t think there are traveling repairmen. :worried: