Y Axis Rough or Jittery

I am at my witts end and wondering if I should just cut my losses and sell my machine.

I am having serious problems getting my 1000mm xcarve to make smooth cuts. Unsure how to describe it but my Y Axis is just not moving smoothly.

If I tighten the v wheels I start blowing nema motors or controller boards on the xcontroller. If I loosen them again just no Improvement but I’m at least not destroying xcontroller boards or nema motors.


Can see what I’m talking about here. Just can’t get smooth cuts.

I’ve had this machine for a year and we just can’t get it to run how we Think it should.

We are in major financial hell right now as I had a heart attack last year and this xcarve cnc was supposed to allow me to continue Making furniture as I simply can’t stand the physical needs to stand up running a band saw for hours a day.

Is there a fix for this or should I just sell the machine for $300-500. It is the 1000mm machine but no chance I can ask a buyer to pay near retail price when I can’t even get it to work for me.

My fear now is the more I continue to spend my time trying to fix this the added streess and anxiety could result In a repeated heart attack which is my worst nightmare.

As it stands we have an order we need done for June 27th. That order let’s us keep our house. Needless to say I nee this to work or for it to find a new home.

Sorry to hear that.
Looks like a mechanical issue to me. Even though I only had electrical issues, some things come to my mind, which are mentioned more or less frequently in the forum:

  • Are your belts tight (so you have no slipping)?
  • Are your wheels correctly tightened (should be movable with 2 fingers)
  • Is your belt okay (no tooth missing etc)
  • Check every screw again, especially the one on the pulleys
  • What are your cut settings? Is the path wobbly as well when just jogging the machine? (Maybe to a test with a marker, so you can see whether the problem occurs without any heavy load)

I hope someone else with a deeper knowledge will have a solution for you, that would just be the things I would check first personally.

2 Likes

Your images show that the bit is biting into the stock creating serious deflection.
What are your cut parameters like bit diameter/RPM/feed rate/depth per pass etc?
Have you trammed your router?

My initial thought is that you are either going too aggressively or have rigidity and/or tram issues.

3 Likes

I have tried a variety of settings in terms of speed and even reduced the depth per plunge.

What’s happening is every pass the bit ends up following a completely separate path.

We initially had things run great the first 2-4 weeks we had the machine and then all hell broke loose.

In terms of belts they are tight but not overly tight. We have the wheels to a point where we’ve had them moving freely to also trying having them more snug.

Doesn’t seem to matter what we do it just won’t cooperate.

I’m at a point where we are considering going to the places here that offer guaranteed financing and then upgrading to a direct Z axis drive while also converting the X and Y Axis to all be direct screw mounts instead of belts.

It’s all confusing and aggravating. We built a very sturdy table from solid bamboo that has helped immensely with ensuring the rigidity of the machine itself is kept in place.

We have tried using aftermarket spindle mounts as well which has no change. If anything made it worse.

I’ve ordered a Hitachi M12VC Router to see if the router itself can help. If anything just having it run quieter will at least make my wife happy.

At the moment she’s really upset that we invested this kind of money into a machine that has been a lemon from early on.

One thing we can say customer service from inventables has been amazing. They’ve helped us with replacement when the xcontroller was blowing boards. One of the two Y Axis motors was for whatever reason creating power surges even though when we pulled it was still moving as you’d normally expect but if we plugged it back in and ran it we would blow xcontroller boards within hours.

Just so unsure what to do as we can’t afford this machine not to work. It’s gonna cost $1200 to upgrade to direct Z axis with direct drive for both X and Y Axis as well. Only advantage there is you know it’s gonna work.

Just though to swallow that when your mortgage is in arrears.

Something is loose.

Can you in detail tell us what your cut parameters where for the sample you had images of?
Bit info, diameter/flutes
RPM?

The std belts are weaker as span increase, wether they are a root cause or just adding in is hard to tell.

2 Likes

Understandable, I still think by eliminating the possible problem sources in a structured manner your problem will be solved.
Can you give answers to @HaldorLonningdal and my question, to rule out that error sources?
Furthermore (just for clarification):

  • Wheels should be snug but turnable with 1-2 fingers.
  • “tight but not overly tight”: do you have a fish scale and did you measure how much force you need to apply to your belt to pull it 1 inch upwards in the middle of the belt?
  • I don’t think your problem is your z axis, so a direct drive z axis probably won’t fix it.

Backing this. My first thought as well.

1 Like

Kevin were are you located? If someone is close to you you might get some personal help. I drove about an hour to help a guy out here in the Cincinnati area. Took me about an hour to get his running. Steve

3 Likes

Triple checked nothing is loose. The v wheels on the Y Axis move freely and are slightly snug. Just makes less than zero sense to me.

Either way I am not buying a CNC in the future that uses belts. After getting a look at the direct screw drives I don’t even understand why all the popular cnc come with belts as the oem solution.

So I tightened the adjustable v wheels on the Y Axis again making sure they were snug to the rails and here I am again back at the same original problem we’ve been having.

I can clearly see one of the two Y Axis motors being dragged off and on. Whenever this happens for more than a few minutes it will either kill one of the Nema 23 motors or worse the board in the x-controller will physically short itself out.

I’m just ready to light a match with this machine at this point as it doesn’t matter what we do we can’t get it work as it should from the factory instructions we have followed to a tee now 3 times.

I’m way north in Canada. Was actually a big reason we went xcarve over shapeoko as the shipping was Significantly better. Just at a point now where I’m at a loss and will just need to sell it to recoup whatever I can or somehow get the finances to do the direct drive upgrade.

Just some random ideas of what you could check.

Motor wiring. Maybe a bad connection on one of the Y’s.

Driver current, Maybe not set high enough or maybe to high and it’s over heating.

Even though the pulleys are pressed on you could still have a loose one.

Hope you find a solution.

Are both Y-steppers really wired correctly, all wires good?

If they are:

  • the setup should be almost fool proof as an overloaded stepper will simply stall out
  • Even with current limit set to max on the Xcontroller you´ll only risk overheating the steppers. Are they hot?
  • Overtemp protection of the driver kicks in if its taxed beyond its limits

You have not provided any information of your RPM/Bit/Feedrate/depth per pass etc yet, please provide an example of that.

Do you have any pictures of your machine, please get details shots in case we may see something obvious :slight_smile:
If you want us to try to help details are welcomed :slight_smile:

Then put a match to it if so inclined.

5 Likes

There are a lot of people here who’d like to help but we need more details. A video of the machine in action would be really helpful too. The machine is capable of making pretty good carvings so have faith. The problem is not insurmountable.