Y axis suddenly offsetting during carving

I just finished setting up x-carve 500mmx500 mm with nema 23 motor and dewalt 611 router. I tried to cut some round shape and square, but in the middle of carving, the machine moves incorrectly in Y axis. I tried to tighten up the pulling belts but no success. The Dewalt router is powered separately. Is nema 23 motor is too much for my machine? Any suggestion will be appreciated.

Check your pulley screws, sound like one could be slipping

Don’t overtighten the belts, that can cause lost steps. There’s a lot of things that can cause lost steps while you’re dialing in a new machine, the easiest things to check are the potentiometers (pots), pulleys, V-wheels, and belt tension.

There’s 2 threads you may be interested in. I set one up with a bunch of videos I made to help dial in a new machine:

The second thread is a great guide to potential problems causing lost steps:

Check them both out, between my videos and @LarryM’s guide you should be able to get everything sorted out. If you can’t figure it out, or if you have questions, don’t hesitate to ask. There’s a lot of great folks on here that are willing to help you troubleshoot problems. :smile:

Thanks for your suggestion. I think I did overtighten the belt… I will try to check all things you suggested.

Finally I was able to sit down and tweak the potentiometers as you shown in the video and now the machine works wonderfully!
Thanks a bunch!!