Y axis will not stay square to X axis while jogging to work piece

Well… I have had the x carve for over a year and never have had it run smoothly for over an hour without destroying a nice piece of wood. I have tried adjusting v wheels, belts, squaring the frame numerous times. I have upgraded to the stiffer Y axis, and all other upgrades. The machine works worse than it ever has. The Y axis will not even stay square just trying to jog it over to work piece after homing let alone cut accurately. I am going to try for another week to rectify this and if I cant I guess it’s time to sell. I have wasted numerous precious hours in my shop accomplishing little or nothing and wasted more than a few dollars now on nice wood.

What size and version of the machine? have you upgraded to the new eccentric spacers ? What spindle ? Have you checked/adjusted your pots and steps per mm? When you assembled did you use loc tite?
How are your belts secured tape, glue, new style clips? V wheels adjusted correctly ? I know it’s a lot but all things to consider it takes some time to get it dialed in

Sounds like the motors are unlocked. Take a look at this.

After a day of not being able to get the machine to home properly I got all limit switches working this morning and tried a few test cuts. First I cut a circle…came out perfect. Than I cut a square…perfect. Than for the third test i tried to cut a circle and square that were open in the same file… malfunction. Tried again worse, tried again worse. The belts are tight, nuts are tight. Frame is square. I did notice than with the machine off I pushed the Y axis nearly as far north as it will travel and than switched the machine on to home with the limit switches… half way back the Y axis starts chattering nearly to the last 5 inches of travel before hitting the limit switch. Here are the photos of test cuts. The middle photo is the first and good test. The top photo was second and the bottom photo was the last test cut.

I have checked the v wheels and fixed wheels. Everything is tight but still able to rotate wheels by hand. Adjusted belts. I have not attempted to tear the controller apart and change pot settings for motors.

Both axis are pushing back and forth smoothly. I watched a video on Youtube about adjust the concentric nuts on the v wheels. I no longer have an any binding noise when I move both axis back and forth. Still the Y axis is chattering as soon as I attempt to home to limit switches and starting two days ago it intermittently gets stuck now on the Y limit switch giving me an error message that there is an obstruction. I did open up the x controller to check power pots and it looked like 2 o clock position as prescribed. I pushed the power up slightly and it has made no difference. I have spent hours trying to adjust the v wheels. Yet I remain optimistic that this will be resolved! Failure is not an option… Thanks everyone for your time.

Have not tried swapping. Will do tomorrow!

Did 1 of your y motors wires come loose an the y is racking?

Thanks to the forum and David Annetta’s suggestion to look for loose wiring, my machine is running smooth. Loose wires were the culprit. I used crimp connectors with flanges that looked very neat but can fail and cant be detected by eye. I have gotten rid of all the connectors and attached wires directly to screws on the terminal block. Thanks again.


We only know these fixes cause we’ve had these problems. Good the hear everything is running smooth.