Y carriage jams on rapid movements

Hey guys

I’ve been using the xcarve for a few weeks now and so far it’s been great. At least until I tried to carve something pretty large on the 1000x1000 machine. It seems that whenever the gantry tries to rapid move more than 50mm at once (even when manually imputing home positioning), the gantry would stall then recover. While its mildly annoying during manual homing, it’s really bad when that happens during a carve as I end up wasting a large chunk of material. Are there any explanations for this? I’ve already tensioned the belts tightly so that’s not the problem. Any input is greatly appreciated thanks!!

Check small nuts on pulleys make sure one of them has contact on the flat spot on the motor axle.
If it stops then continues the movement is sounds like the pulley is slipping on the axle to me.

almost sounds like there could be a problem between the Y axis rails that’s causing inconsistency. Could be a pulley like Ebr mentioned. Could also be a wiring issue causing steps to drop on one of the motors, jamming up the gantry as one side drags behind the other, but this could even be something with the belts/pulleys/idlers not being properly tightened/aligned.

I don’t know if your issue is the same, but I found a similar problem when I changed out my gshield. I had to adjust the pot for the ‘Y’ axis. After the adjustment, I ran the Y axis back and forth with a basic rectangle test utlizing at least 24 inches of run to see how it would react. It helped solve my issue. You may want to give it a try. Good luck

I had the same issue early on. Went through belts, pulleys, enuts and pots. Have not had a problem since July and I run almost every day.

I loc-tighted and where possible doubled up with nylon lock nuts.

Had the same problem. Up the Y-axis current.

After checking what everyone else has said the next place to check is your axes acceleration setting. Depending on your power supply the moters may not have the current levels avalable to give you the acceleration you are asking for.

1 Like

Thanks for all the input guys! Much appreciated! I’ll try all the fixes that you have mentioned and run some tests! I’ll post the results here once I’m done! Thanks again for all the help and have a merry christmas!! =)


Hey guys ITS FIXED!!! The fix was just to increase the amount of current going into the Y Steppers! I just cut a large part that gave me problems previously and it turned out perfect! Thanks again so much for all the replies guys I really appreciate it!! Once again thanks and Merry Christmas!! =D



Just about everyone has to up the Y-axis current.