Z Axis binding

I have a 1000mm x 1000mm x-carve with NEMA 17 motors, ANSE Z bolt, and a Dewalt 611. When I within an inch and half or so of being topped out my motor cannot turn the ANSE Z Screw. However, I can turn it with very little resistance when a wrench. From 1.5" from top to 2" the motor will move the screw but not smoothly, it jerks. Once I get below 2 inches from the top the screw moves smoothly.

I’ve checked all the v-wheels and they seem fine, and wiring all looks correct. Any suggestions?

I removed the Dewalt 611 and the ACME screw appears to be bent? I can see it moving closer and further away from they Y axis gantry as the screw turns.

Not sure if this is an issue, just trying to provide more information.

I just assembled my 1000 x 1000 a day or two ago and noticed the same thing re the ACME screw seems to be angled away… the Dewalt 611 hit the top of the unit and struggles until it reaches the home position. I read that others had the issue. I am able to do some basic shape outline carvings but am brand new so not sure whether this is an issue either.

I should add that I have the NEMA 23 motors and increased the Z-axis POTS a bit as well as bending the limit switch down a little so it will hopefully stop sooner. I might take a file to the Dewalt case… does yours touch?

My Dewalt 611 did barely make contact with the top plate that contains the bushing the ACME screw rides in. It appeared to just be contacting the raised warning notice. I filed that down, and am no longer making contact, but it hasn’t resolved the issue. I see the same issue when the 611 isn’t mounted, the z axis still binds near the top of it’s travel.

It looks like this is due to the motor-mount plate (or bearing pocket) being offset slightly from where it should be, not a problem with the lead-screw or nut.

I had a similar problem. Look to see if the Lead screw bearing is hitting the maker slide before it is fully seated. I dremeled the maker slide so that the bearing can protrude below the mounting plate. The bearing hole on the mounting plate is over sized. On my machine I have to pull it all the way forward to have proper alignment with the Acme nut. With these steps my Z runs very well. Do not run the machine until this is corrected. I ran mine for an hour and my lead screw was bent and the nut worn. Inventables service was great getting me a new nut. I straightened the lead screw. Also do not over tighten the timing belt.


Remove the Acme screw and roll it on a perfectly flat surface. You should see a slight wobble in the overal length of the Rod. If you do not see a wobble then the Rod is fine and your pots need to be adjusted.

My acme Rod arrived slightly bent in approximately the same area. I contacted INVENTABLES and they rushed me a replacement. No issues with it now.

This is how I resolved my issue:
Turned out to be a lot of friction between the 8mm pulley and the flange bearing!
I added a 8mm washer and some oil and the rod turns much more freely.
Still field testing it, and will update if anything changes.

That’s good advice. I’ll check this out when I get home tonight. Hopefully mine is not bent as it wasn’t readily apparent until I read this post that it was angled. I was able to find a rotation where the Dewalt 611 where it just clears the mounting plate by a fraction. I’m not sure if there’s a way to post a photo

My concern is that the rod turns very smoothly in the latter 3/4 of it’s length. It’s only near the top that it starts binding. The first piece I cut was only .75" thick. Then I tried to cut a 1.75" thick board and the z axis refused to move.

Have you tried to shim the rod nut if it is not aligned very closely it will work just fine at the bottom and the closer it gets to the top the rod loses its “flex” and will bind.