Z Axis Calibration Issues

Hi - My son gave me a Shapeoko 2 with upgrade parts to make it into an X-Carve. (He didn’t have time to use it)
Everything is set up and running correctly. The X and Y Axis are calibrated.
When I try and calibrate the Z Axis $102 = 375 gets me exactly 1/2 of target height change. So I need to set $102 to 750 but the motor will not function properly above 500. I have tried changing step settings and no matter what combinations that I have tried I get run into the same problems. (When I use G Code Sender Calibration I can move 1 mm at a time and 750 calibrates fine but when I try to run the motor 50 mm at one time the motor will stop and hum).
The Z Axis upgrade did come with a 20 tooth pulley and a 40 tooth pulley. Changing to the 40 tooth could solve the problem but the belts that came with the kit don’t fit that pulley. All of the youtubes that I have watched show the 20 tooth wheel being used. (I am using NEMA 23 400 step motors).
Do you have ideas on how to solve this problem?

Have you changed the microstepping setting?

Yes - Yesterday I tried at several step settings. 200 steps seems to be the most logical and consistent with what I read that others are using but the motor stutters or stops when going down. 400 steps seems to work the smoothest but can not calibrate.
This morning I went back to 200 steps and changed $122 to 20 instead of 25. That seems to be working and calibrates fine. I have not tried doing any carving yet but will do that when I get some time. Will follow up.