Z Axis Changing Directions

I am having a strange Z axis issue. I have checked the forum for similar issues but didn’t see a post with an issue like mine. I received my X-Carve 500mm, Grbl Shield, Nema 23 motors. I finished putting my machine together a couple of weeks ago. I did the setup using Easel, everything worked fine. Then i did two test cuts using Easel, everything worked great. After two week away for work, i finally got back to my machine tonight and was going to run a couple of more test cuts before starting some serious projects. I logged in to Easel to redo setup, but when i tried to jog the Z axis, it would jog up and down using the same arrow. If i pushed the up arrow it would go up a couple of times then go down the third or fourth time i tried it. When i pushed the down arrow, it may go down or may go up. I unhooked the machine, reset everything, and tried again with the same result. I have put together a Shapeoko 2 and a 3D printer, but never seen anything like this. I checked all the wires with no issues.
I decide to try jogging with Universal G-code Sender. It connected with no problem. I jogged the X and Y with no issues, but the exact same issue happened with the Z. Anyone have any suggestions?

Check to make sure that the gShield is plugged into the Arduino firmly. Since there’s nothing holding it down it may have come loose. I have some plastic spacers in my setup to hold the board down on the Arduino. If you have an intermittent connection reseating the gShield would help.

also check the black and green wire for the z axis, where they connect into the gshield. the connection might be loose.

Got the Z axis working. I just rewired it to the Grbl shield and it started. Now the spindle won’t turn. It was working fine last night. Oh well. My luck. I’ll try troubleshooting it later today. Thanks for the responses.

If you power up your spindle and it won’t turn on, try giving it a “kinetic adjustment”, or give it a little push to get it going. If it starts up then, you’ve got a faulty spindle and should contact support.

I have the spindle working. The problem was a wire i must have pulled loose on the X-Carve itself when i was trying to fix the Z axis. It is the stock spindle, but I do have a Dewalt 611 on the way. I wanted the quieter spindle since I will be using it in an attached garage, but i’m not going to be running it in the middle of the night. I finally broke down this afternoon and checked every connection on the X-Carve itself and re-secured any that was questionable. I then removed the Grbl shield, unwired everything, made sure i had good clean ends and re- wired everything. For the moment everything is working great. One thing i did learn is where the wires run into the enclosure was rubbing the shielding off. I put electrical tape around all wires as protection. Thanks for all the help.