Z-Axis consistently cuts the wrong depth

I’ve managed to get my machine put together, setup through easel, and get my X and Y axes calibrated to where my machine can cut a perfect circle or square out and cut right where I need it to. I cannot, however, figure out the Z-axis for the life of me. To calibrate X and Y axes, I used the formula where you divide the distance you want traveled by the actual distance traveled, and then multiply that number by the current step/mm setting in the machine inspector to get the new step/mm setting. I’ve tried that with the Z-axis, but the depth on my machine seems to be practically random each time regardless of how many times I calculate it. I even tried cutting the same exact shape at a depth of .125" twice without changing anything whatsoever, but it still managed to cut it at .068" the first time and .163" the second time.

1000x1000 X-Carve
Dewalt 611 Spindle

Things I’ve tried:
-I’ve done the Easel Setup at least 25 times over the course of trying to figure it out. Originally, I had the M8 Threaded Rod set as my Z-Axis, but I’ve since corrected it to the ACME but still have issues.
-I always make sure the bit is just barely touching the top of the material
-The bit is securely in the spindle
-The material and the waste board are flat (As far as I can tell, I’m getting consistent depth across the shape each time I cut, the depth is just completely wrong each time).

Things I’m not sure about:
-I’ve read that all of the wheels have to be tightened to where you CAN’T move them with your finger, but also I’ve read that they have to be just tight enough that you CAN barely move them with your finger. I don’t know what’s correct.
-What is the 2x Micro Stepper? I can’t find enough info on it to see if that’s a possible solution.
-A side view of my Z-Axis shows that the plate that the motor is attached to is not level with the ground/board or perfectly straight. I noticed when I attached it that the plate had a slight bend to it, but I assumed this was normal. Is this normal?
You can see the bend is right where the Z motor’s shaft connects to the plate on the left - http://imgur.com/TOpUY1W
-The Machine Inspector has all of the values in MM, but the Step Interval on the right side of the window that popups when you hit “Carve” is set at 0.1 Inches. Would this cause an issue only for the Z-Axis?

I have my V-wheels set to where I can spin them fairly easily with two fingers, but with a little more force with a single finger. You may also need to bump up the pot for the Z axis, especially if this is a brand new machine. If your plastic nut isn’t fully worn to fit, or if your shaft has a little bit of a bend in it, the nut occasionally require more force to get through the area of high friction. Fortunately, that will work itself out shortly.

You may want to check that the pulley screw on the Z axis is actually dead center on the flat milled on the stepper motor shaft, and isn’t loose. Also make sure the belt isn’t ridiculously tight, I used an allen wrench between the motor and the slide to apply just a little bit of force backward when I was tightening up the bolts to hold it in position.

I’m not sure why your plate has that bend on it, you may want to compensate for it by throwing a washer or two between the motor and the plate where it’s not bent just so it’s more aligned with the threaded rod.

The mm->inch difference between Machine Inspector and Carve shouldn’t cause any problems for the Z-axis, just make sure when you do your Z calibration that you’re either doing it in mm or are converting from inches to mm.

If the plate arrived like that, you can always contact Inventables and request a replacement. Their customer service is the best I’ve ever seen.

1 Like

I would turn the pot up a bit on that axis, I had an issue with a surfacing bit that was so out of balance it triggered the z to start going down into my waste board. noise can trigger or stop a motor, not sure how the out of balance bit made it start to turn but it did for me.

I noticed Robert mentioned to “turn the pot up” on the Z-axis, but what exactly does that mean? Also, If the angle of the ACME rod due to the plate being bent was the issue, wouldn’t that also mess up the Y-axis of anything I tried to cut and not so much the Z-axis? As far as I can tell, I don’t have any issue with the Y or X axes

If the z axis is not going proper repeated depth then something is causing a signal interruption making the computer think it made it to the desired depth.