Z-Axis Cuts Deeper Than Easel Setting

After several tests I notice that my X-Carve 750mm cuts 0.040 in deeper that the cut setting in Easel.

I have calibrated the machine, checked the settings and made sure I zero the Z-Axis precisely when setting up the carve.

Thoughts welcome.


Carve this test:

Face the plane of you solid and then carve a pocket 1/2" deep.
What is the actual measured depth?
(make no adjustments between face plane and pocket carve.)

Will give it a try this evening

Thanks in advance

During the Carve sequence I lower the Z-Axis until the bit touches the
material surface with a piece of paper laying on top to a point where I can’t pull the paper free.


I tend to default to inches - I will try running some tests in Metric.
I use mm to lower the bit to the surface during setup

I designed my test for 1/8" .125 in
Cut depth actual was .165 in

.165 inch relative to what?

We are trying to determine wether a recalibration is in order or if it is your machine/work flow that need adjustment :slight_smile:
Try to provide us with factual information on the questions Phil asked, and also what depth you measure on my suggested test carve.

1 Like

Sorry working to get the hang of this technology
Thanks for your patience

I will run the test this weekend - hopefully today.
Got home too late yesterday.


I ran the test that HaldorLonningdal sent

I did not have any 1/2" Baltic Birch so I used 3/4" for the test and
set the material thichness to 19.0 mm

Large square if recessed from the surface of the material by 1.3 mm
Small inner square is recessed from the larger cut by 6.5 mm or 7.8 mm
from the surface of the material.

Thanks in advance

Robert, the idea behind the two plane carve I suggested to him was to get a known baseline which is the purpose of the larger/shallow pocket. If they are in height 1/4" apart then the calibration of Z-axis is close (hard to measure more precise with only a 1/4" travel)
1/4" = 6.35mm BTW

In my test the wide/shallow pocket was set to 1mm depth and the deep/small pocket to 7.3mm depth, creating nearly a perfect 1/4" change of depth.

OP posted a Z-discrepancy of 1mm (0.040") and this test tells me Z-axis is more precise than that and his discrepancy may be connected to how he set Z-zero. And possibly a close but not just right Z step/mm value.
I would be inclined to reduce the step/mm value by 5% and retry this carve test. :slight_smile:

Which of the following would you like reduced by 5%?

I’m thinking the plunge rate?

Thanks in advance

Those are just feed rates and depth per pass, nothing related to changing/recalibrating the steps/mm values in GRBL.

Video link on how-to:

1 Like

Thanks to all that was informative and very helpful

Shallow Tray is 1.0 mm in all four corners
Deep Tray is 6.2 in all four corners

I plan on doing a full re-calibration on Monday

Thanks again

It not good regarding recalibration, the largest possible travel would be required for that. I mentioned that 1/4" travel is not much to extract precision from.
However, OP mentioned Z went 1mm too deep in most cases (0.040") and my little test clearly show that Z appear to within reasonable spec, atleast not 1mm off. From a 6.3mm Z-change OP measure 6.2-6.5mm and might be from measuring inaccuracies alone.

1 Like

The test I provided had 1mm deep wide pocket with a smaller/deeper pocket set to 6.3mm below that.
If you measure 1.0mm on all corners of wide pocket and 6.2mm of deep pocket then I would say things seem to be working alright :slight_smile:

1 Like

This helped a lot. One question where in the program (easel) did you tell the machine to move 290mm? Im still hung up on that. I do not have any other programs on my computer, only easel.

Thanks wow I’m such a noob

1 Like

I’ve been concentrating on calibration & familiarization as I await arrival of the dust collection system, and making good progress.
Last week, using Robert Rieke’s calibration test pattern and YouTube videos, I adjusted the $100 and $101 parameters. At the same time (after Forum research) I turned on $20-soft limits. As I switched into Z-axis calibration (also using Haldor Lonningdal’s suggested test carve) I ran into an issue.
On the first test carve, the Z-probe process went fine. After measuring those results, I tried to do the second test carve and got hung-up with the Z-probe process. It started, recognized the probe was attached, but I could not get a response with Easel’s jog controls. When I opened the Machine Inspector, it showed the machine was in an “alarm” state.
I shut down, restarted, re-homed and started my Z-axis calibration tests again, but ran into the same problem. So I turned off $20 soft limits.
After restarting and re-homing, I’ve been able to proceed with my calibration test without any issues.
So far, the only parameters I’ve changed are $20 (from off, to on and back to off), $100 and $101, and my forum searches regarding this issue have come up empty.
Just wondering if anyone has any thoughts regarding the use of $20-soft limits, since it appears to be the root of my issue.

Do you have hard limits active?
What are your $130-132 values?

$20 - Hard Limits are Off (0)

Thanks for prompt reply!!!