Z Axis cutting depth after Upgrade


So l upgraded my x-carve (the full works), the x and y axis are spot on and the z axis is fine, however, when trying to cut through, it doesnt. Its about 5 mm off. I’ve got everything set correctly in the grbl settings and all settings are good in the machine inspector. I’ve jogged the z axis also and it jogs perfectly to just say 10mm or 1mm, theres no problem there. But when ive set the workpiece thickness to 12.7mm (just say) it never cuts through. It has on one occasion (idk). I’m abit confused, do l have to calibrate the machine or home it everytime l do a cut?

BTW, l have followed the guides correctly. Ive double checked the settings also.

You should run the Machine Homing sequence when you first start the X-Carve every time. After that, you should not need to rehome it unless you crash it or it looses it’s position for some reason. It is not actually “required” that you even having homing switches, but it is highly recommended.

For every carve, you need to set the X, Y, and Z Work Home position as well based off of your machine, design, and stock; otherwise, GRBL has no idea where your stock actually lies within the machine coordinates. If you are not doing this then that is likely the problem.


Brandon Parker

Are you using a probe for Z zero? and Is that probe setup to the correct size and not 5MM off? (you can check by probing, then using the manual commands to bring the bit back to the material and checking the z work coordinates in the machine inspector)

Also, is the wasteboard surfaced? this would only cause a 5mm issue fairly far away from the location that z zero was set, but regardless a surfaced wasteboard is a must for any CNC…

@SethCNC @BrandonR_Parker

Thank you both for the suggestions.

I’m abit of a newbie in CNC as ive only just out it together last week but ive kinda got the hang of things now. What l normally do is set work piece > set position > probe > then dont move it from there and leave that as my home, unless i know l have to move it back to the corner just say. I did snap one of my homing switches and did a ‘repair’ it works fine but ive got another homing switch coming soon so it could be that, but l doubt it.

@SethCNC I am using a probe, not sure what you meaning by the correct size, isnt the probe ‘meant’ to be correct size? Apologies if that sounds rude. I havent tried manual commands yet but l guess l should.

One thing l did notice was that my z gantry was not aligned correctly, so ive put a shim behind the dewalt spindle mount. I checked everything else was aligned and all was good. ran a through carve and it seems like my wasteboard needs surfacing. I am using a 12.2 plywood and set the cutting depth to 12.7, it cut straight through into the wasteboard, id say atleast 3/4mm and then toard the back of the board, it didnt cut through at all. So i’m guessing it was a few things that has caused the 5mm issue.

  1. incorrect alignment of z gantry
  2. wasteboard needs surfacing.

I’m going to get a sacrificial board, surface that, and then give it another go.

If you are using Easel, you should run back through the machine setup process.

During the Z-Probe setup, you can get to the Advanced Settings here…

Once there, you can update the Z-Probe Touch Plate thickness as shown below. You will need to use a set of calipers to ensure the thickness is exactly correct.


Based on your description of the cutting action above, it definitely sounds like a waste board resurfacing would be a good idea.


Brandon Parker

1 Like

Brandon’s got you covered on the probe thickness setting location I was referencing, you’ll want to use a set of calipers and get the exact thickness of the probe (don’t simply used the measurement that the probe was sold as, they are usually a little off)


But now that you’ve specfied that the front cut through and the back did not… this is an non-parallel wasteboard issue 100%.


Tramming is another process, but this will not effect the cut depth like you are experiencing
Here’s a good video on tramming from Tim over at TKC Worx (you can do the process with a home made tool and feeler gauges too, but his 3d printed tool will get you accurate enough to mill aluminum)


Apologies for the late response.

Ok so l followed your steps on the probe and it was off by only abit, it measured 14.99 and on easel it was set at 15.02, so minor difference.

After doing a few more cuts and differant bits, it all boils down to the spoil board needing surfacing. I’m waiting for my sacrificial board to arrive and will plain that down and hopefully that should solve the issue.

Thank you both for helping out @SethCNC @BrandonR_Parker


So it would appear that the latest update made easel forget everything it knew about my machine, including the Z probe height which had been previously setup in the software. Looks like simplifying adding profiles might have broken those that were already there.

@AndyHawkins Thats very odd. My machine was fine after the upgrade.