Z axis cutting half depth

Im fairly new to cnc and this one has me stumped for awhile. My depth is about half of what it is supposed to be. Cutting 1" material set to cut through it cuts .480ish deep. If i lie to the machine and say its 2.04" thick and cut through it cuts 1" exactly. I have the correct acme thread selected, it does not appear bent, everything tightened and i seem to be able to double it and get it right so I’m thinking gcode or arduino issue. Any ideas would be greatly appreciated!

What program are you using? If multiple programs, is it a problem in every program or just in one?

Is there a chance you’re using the wrong units? The math doesn’t add up, but 10mm (1cm) = .393", which could explain a lot. I’d also recommend doing a calibration, search for “maintenance videos” and you will find a thread with a video I put up on how to calibrate the steppers.

Thanks for the quick replies, I am using easel only right now and typically use mm only. I am going to calibrate the machine today and I’ll let you know what the outcome is. Thanks!

Just in case anyone else gets this issue…I calibrated the machine and could not get it to go over half of the steps/mm it was set on. I replaced the motor and that fixed the problem, after i took the old motor off I could feel it binding as I moved it by hand.

1 Like

Hey Brandon, Mine is cutting to deep. Keeps on making it deeper. If I program an E it will be good and it should stop at the .125 depth I told it but it just keeps cutting deeper. You mentioned that over half the steps where in mm on yours, but I only see the one spot to switch it to inches on Easel. Please help me out Thanks Sam


If you dont have it already download universal Gcode sender, this is what you will need to change the parameters for your machine. If your going that much deeper I have a feeling its not the calibration though, check your pots on your grbl shield for the Z axis and make sure voltage is correct, and also make sure in easel you have selected the correct Z axis drive rod. If your only getting a slight variation from there, you can change parameters on Z axis in universal Gcode sender. To do so, launch UGCS, connect to machine and enter “$$” in the command line, your Z axis should show up around line 20-24 i believe and be defaulted to about 40 steps per mm, you can then use a dial indicator or any other way you can measure the steps and manually change the parameter to fix the issue. Hope this helps