Z axis cutting too deep (Help me pls)

Hi guys! I need your help again! I checked all the existing topics but it could not help me. I use the EleksMill CNC machine and here are my settings. It is perfectly calibrated. My actual cats are about 4mm and I cannot decrease the DEPH. Maybe I should have a look another setting in Easel?

Not quite sure what you are asking about.

When you use Easel to command a 10mm jog up or down, is the travel exactly 10mm aswell?

The max depth you can use with that design is 1mm, as seen at upper right: Cast Acrylic 130x90x1mm
The 1mm number define max depth, to reach deeper you need to alter the thickness of your material.

How did you set Z zero?
Can you post your grbl settings?