Z axis doesn't retract all the way during homing

So what does this mean…? I’ve adjusted the pot and tested the accuracy. I program 2 inches of upward movement. Measure and sure enough it has moved up exactly 2 inches. But no matter what I do, it wont retract all the way and trigger the homing switch during homing. It travels smoothly the entire distance up to the homing switch when I program a movement long enough. I’ve got an ACME rod with a Dewalt 611. I’m using Easel in Chrome, have restarted the computer many times.

Check your connections where it goes on to the gshield, also make sure your wires where placed in the right order

Are you sure Dewalt is not hitting motor plate on top. ?!

if the other suggestions aren’t the issue, try bumping up the POT for the Z axis on the gShield just a tad… see if that helps

I don’t think it’s current issue. His Z is going to certain point than stopping if I didn’t understand wrong. Something holding it .Or maybe he didn’t machine setup for Acme rod and stopping after turning too many turns. I think there is a revolution limit for homing position.

Thanks for the responses. To clear a few things up:

1.The machine has been running fine prior to this Z axis issue for about a month, so I don’t think it’s a wiring issue.
2.There is nothing mechanically stoping the z axis from moving all the way to the homing switch. The 611 spindle has been ground down as has plenty of clearance.
3.The amount that the Z axis moves during the homing sequence seems to vary. Sometimes it only goes about an inch other times it almost goes to the top.

I can try bumping the pot up some more, but I’ve already bumped it up twice. But if it is moving the correct distance (I ask it to move 2" and it moves exactly 2inches), should it need further pot bumping just to activate the homing switch…?

I still would look into the wiring or your solder joints on the right angle you soldered, it’s a real easy place for something to come loose. it happen to me a while back out of no where

I had the same issue when I first set mine up. The Z-axis would go all the way up but stop just short of triggering the homing switch. For me, I bumped up the pot until it triggered the switch and all was fine.

It could be binding at the top slightly and that might be enough to cause it to grind to a halt… maybe?

1 Like

I had this issue the very first time I tried to home it after just completing the build. It hasn’t happened since. My suspicion is that the delrin nut just needed a little break-in time to allow the acme rod to not bind.

I have confirmed that there is no mechanical binding, interference or hang up’s whatsoever. Super smooth movement when using machine control for the entire length of the Z axis travel. I ran a few projects and I think one or two out of six the Z axis retracted completely during the homing sequence. Could there be something to whether or not I have restarted Chrome prior to opening the project and homing…? Thats the only thing I can think of that may have changed between projects.


If you are absolutely positive that you are not having a mechanical binding, then you may be seeing a false trigger of the homing switch due to electrical noise from the stepper motors and/or the DeWalt.

When the Z axis stops moving, is it in the same position, or is the position where it stops random?

Do you have shielded wire for your homing switches or the wire that Inventables sends with the kit?

You could try moving the routing of the power cable to the DeWalt to see if that makes any difference.