Z axis goes straight down and nothing else happens when I hit “Carve”

I just set up my xcarve. As soon as I hit the “carve” button in Easle, the z axis just plunges Straight down and that’s all the movement the machine does. It does have a upgraded z-axis on it but this problem did not happen until I unplugged the entire machine and moved it to a different building and plugged it back in

Does it jog correctly?

You can also share your project or g-code file so others can see if the design/code provide clues.

Yes the X, Y, and Z axis all jog perfectly fine

How do I find the g code for what I have drawn in Easle?

Click Machine -> Advanced -> Generate G-code

Or share the Easel file
File -> Share -> Shared with link (copy URL) and hit Save.
Post URL here

Ohhh ok. I finally figured out what the problem was.

I have the 1000 x 1000 mm rail x carve, but I bought the upgraded Z axis from cnc4newbies.com

The link for the upgraded Z axis I have is:

The upgraded z-axis has a ballscrew I’m it, not a piece of all thread, so when I set the machine up for the first time I clicked on the “acme thread“ instead of the “M8 threaded rod“ and that was the correct setting, BUT… the thread pitch on the ballscrew is a LOT steeper than the default “Acme thread”setting.

The fix for this is:

Go to Machine>



Enter this command:


Then press “Enter” on your keyboard

By doing that you are changing the command formula for revolutions per inch on the z-axis to match the pitch of the ball screw on the upgraded z-axis