Z Axis is not going to right Depth

Ok so i have had my xcarve for about 6 months or so and only the last month started to notice that the depth i and wanting to go and the depth the machine goes is about half off. For instance if i want to move up or down on the z axis an inch the machine will only travel 1/2 inch. I have adjusted my z axis power adjuster ( i think that is what it is) on the arduino where the z axis wires plug in, and to no good i still can not get it to move the proper amount. I am using grbl as my gcode program for machining. If anyone has any advice i would greatly appretiate the help.

Do you have an ACME or M8 threaded rod on the Z?

You make a choice when you do the first time setup in Easel. Perphaps you chose the wrong option ?

1 Like

I have m8 but i dont use easel i use grbl

It is called a potentiometer. It adjusts the current through each stepper motor, which affects the overall power.

All CNC programs (Easel, V-Carve, Fusion 360) use GRBL. So unfortunately your statement does not make any sense.
Like Ebr suggested, use Easel to configure your GRBL to match the M8 thread.
Since you seem opposed to using Easel, use UGS (Universal GCode Sender) to manually type in the Z Axis’s steps per mm.

Also, check your GShield’s Z Axis MicroSteps jumper setting. It should be set to 2X microsteps. See the [electronics instructions and pictures][1].

Then check/calibrate your Z-Axis. Tell it to raise 0.25 inches. Can a 1/4" bit roll underneath (with no play/slop)? You know your Z-Axis is at least 90% correct when you can.
[1]: http://x-carve-instructions.inventables.com/step14/

I’m having the same issue, now. Here’s what happened:

X-carve built and running fine - no issues ever.
Today I plugged up my laptop to run a cut and just as I started cutting a pop up on my computer lead me to the “this program wants to make changes to your computer” screen. The bit instantly plunged into my work piece. I quickly aborted the cut, after plunging through my piece, my waste board, and causing burning and smoke from my wood.

Now, it seems, my Z control is totally off. Cuts are all shallow!

I checked all eccentric nuts, I reset all my machine settings (acme screw and what not). I also, jogged the z all the way up and all the way down - didn’t notice anything. I unplugged everything and let it sit for hours (power cycle) - still no improvement.

Should I adjust my potentiometer - would that even make sense?

Thanks, in advance, for the help!!!