Z axis is sticking

It seems the v wheels are slightly loose but everytime the z axis tries to move, I feel the piece that goes around the threaded rod is just way too tight. The stepper is spinning and the thing just wont move.

Video attached hopefully

It wont attach

So everything spins. Just wont move.

Correction. The rod is not spinning. It gets stuck on the rubber thing.

Very technical naming. Lol

Sounds like the set screws are lose on the pulley on the top of the rod.

this? That as right as possible

Did you put blue loctite on the screws when you put it together?

Did you adjust the potentiometer for the Z axis properly?

1 Like

Aaaaaaamd we have a winner! @JustinBusby.
Finally we got to the pots. Your going to want to check the voltage from the controller going to the motors and see if your under powered.
Y pots go to the max. Then the others you will tune.
And of course Check All the machnicals Every time Any issue.

Not with the X-controller.

Set all current limits at 2.8 if you have the NEMA 23 stepper motors.

1 Like

But there are two y motors. Double the voltage. No?

I am beyond confused.

I have the controller it came with. All the voltage switches are set according to the directions. I do not think it is under powered if it is set the way it is supposed to be set. The rod is WAY too tight on the black rubber thing. Everything is as tight as possible.

What gap?

It was the 2 tiny screws… I tightened them again. It works now. It’s hard to tighten those with a eyeglass driver. -__-

The X-controller has a dedicated driver for each motor. Four drivers, four motors.
No sharing of drivers.

1 Like

I have Allen keys… it’s not an Allen. I had to buy a eyeglass screwdriver

We joke a lot about blue locktite on the forum, but it will keep those screws from getting loose. Blue locktite 242 works well on the pulley screws.

Yeah… only issue now is the bit sometimes doesn’t raise enough and causes this

I tried to sand it down but it’s too deep

You are experiencing lost steps for some reason. If the pulley you have tightened earlier isnt seated properly is can cause slight slippage, causing the Z to not retract to intended height, in effect carving lower and lower.

Another possible reason could be that the delrin block (black plastic) that goes around the srew is tightened to hard to the carriage. It should only be firm, not tight.

A third possible reason could be poor contact on one of the four stepper wires.

1 Like