Z Axis Issue

Kinda frustrated, after ruining several expensive pieces of 1" walnut I’m giving up till I can get some help. My Z stepper motor keeps making very weird noises and losing it’s position sometimes high sometimes low. I tried the following,

  1. Raising the pedometer
  2. Checked my belt
  3. Checked the acme rod and nut
  4. Checked the pulleys

The only thing I can think of at this point is a faulty stepper motor. Is there anything I haven’t checked?

Are the eccentric nuts allowing the axis to move? Too lose…too tight?

I had a bad Z motor, but it is much more likely that there is a lose wire somewhere in the Z motor connections. My X motor was acting wonky at first and I found that there was a single thin stand of the green wire had escaped from the Grbl shield connector and was touching a trace below the connector occasionally.

Tell it to jog two inches and then move the wires at every connection point to see if it skips.

If the wiring is solid be sure the pulley set screw is very tight on the flat part of the shaft. I noticed that it can take a lot of force to turn the screw on some parts of the travel due to the delrin nut rubbing the Z plate. If the pulley is not super tight it can slip.

Also check to see if you can turn the screw by hand? If not the eccentric nuts may need adjusting. I would also suggest spraying some dry lubricant on the screw.

I have a big laundry list of things to try from the guys at inventables, but its weird as it happens at different times, sometimes an hour into the project, sometimes ten minutes. Eccentric nuts are fine, wiring seems fine even when I wiggle them when it’s moving. Going to try my feed rates and depths, but I don’t think that’s it as it happen with a piece of soft pine at .028 per pass and 28/28 on the plunge/feed rates. I think tomorrow i’ll try it on cheap foam at the same rates and see if that has a issue as it should easily be able to run 3 times as fast with the foam. The down time and wasted material is the worst part of it :rage: Just kinda want it to work right already, had to replace the spindle last week. Just kinda wondering what the next issue after this will be :frowning: On the good side my zero touch plate came in and works great with Chilipepper. I’m sure it will all get straightened out Sigh… just needed to vent. (Still haven’t gotten around to fixing my homing issue. on like my 6th switch, glad I bought a big bag)

The same thing happened to me, I solved by loosening the screws ACME nut

Actually I believe I figured it out or it could be a secondary issue (my second spindle died today) I believe it was dropping rpms while cutting deep and must of been getting caught and skipping steps. Then again I won’t know until I get back up and running it’s completely dead now unless I know it

How do you do this (loosen the nut)?

Well i’m back up and running, wound up being a bad Z axis cable. Seems it must of had a break in the middle where. picked up a new one at Home Depot and i’m all good now.

1 Like