Z-Axis Kills Machine When Jogged - X/Y Axis Function Properly

Hi All,

First time posting here, but I’ve found the forum very useful for other troubleshooting problems. This one is unique and can’t figure out if my motor is bad, or what the issue could be. When I start up my X-Carve (1000mm), the computer (WIN10 - Google Chrome) recognizes the machine, the CARVE button turns green and everything seems normal. The software is up to date, and if I go to jog the machine, the X and Y function just like they should, however if I jog the Z-Axis the machine freezes up and won’t move. Then I am not able to jog the X or Y axis after this happens, until I restart the machine (X-controller).

The whole system was working fine yesterday and everything was working as expected. Any ideas and troubleshooting would be greatly appreciated.


Update for anyone who has seen this. Machine still does not work properly, but I did change the X-Axis and Z-Axis wiring just to test and make sure the Z-Axis motor was still functional. When I swapped, the Z-Axis motor did work when I hit the X-Axis jog button, but when I hit the Z-Axis jog button on the computer (which the motor was confirmed working when plugged into the proper X-Axis motor, the machine locked up again. So all 3 motors to function, it seems like it might be a software or X-controller issue.

May be a bad driver/board.

I had the exact same problem some time ago and needlessly ordered a new board for my X-Controller… it wound up being a line in the GRBL code had somehow had some values changed… (X axis I think). I don’t remember exactly which line it was, but if you $$ and copy/paste the resulting code here, I am sure someone can point out the error in your GRBL code.

1 Like

Thanks for the feedback. I’m attaching a copy of the GRBL code, although I have no idea how to descipher it… :slight_smile:

I would love it if the fix were software, but it’s possible I need to order a new driver board too. Any help would be appreciated.
Cyclone_TV_Cabinet.nc (135.4 KB)

Not the code you are trying to cut, The machine settings…
I believe you should specifically be looking at the value for line 100.
In Easel, Go to the machine console or “Machine inspector” (Machine> Advanced> Machine inspector and in the console line enter $$.
copy the 20 or so lines of code you see and paste it into a reply here. I’m sure that then we can figure out if your machine settings are wrong.

AH! Thanks for the reply and appreciate the assistance. I checked Ian’s post but not exactly sure what to change.

Below is the code of the machine at idle before any commands are sent to the machine:


This is the same thing after I lock up the machine when the Z-axis is jogged.

G91 G21 G0 Y-2.5400
G91 G21 G0 Y-2.5400

your $102 value (which governs the step increment for your Z axis) is way out of the ballpark.
a well calibrated xcarve should have a $102 value somewhere between 180 to 190.
I just looked at my machine and my $102 value is 188.125

To change this go into the machine console again and type in

$102=188 (enter)
then type $$ (enter) and verify that the $102 setting has changed.
if it has saved, go ahead and try to jog the machine. BE CAREFUL, Use a small jog increment as a setting of 188 works on my machine but may move your Z axis differently than it does on my machine… (only a little more or a little less travel)

I hope this helps


Indeed, this tells the controller that is needs to perform 2.1million steps to move 1mm. Bad data :slight_smile:
Do what Robert tells you, it should remedy the situation. (a fine calibration of your exact $102 may be required anyway afterwards)

Hi i am away until Saturday night. But when i get home i can put my settings for my woodpecker up.
There is a youtube video up thats tells you how to calibrate your X,Y and Z axis correctly. It helped a lot.

That worked! Thank you very much for the information. Yes, changing the $102 value made it not freeze up and now it appears to be working good again. Thanks for saving my bacon!

I would reccomend copying your $$ settings to a notepad or word document and saving it for future reference.
You also may want to consider goint to Triquetra-CNC and get a copy of the calibration worksheet in order to dial in your Steps per mm and overall accuracy.

Hi JustinMetras as promised my settings for 3018 woodpecker

Hi [CTRL+X] < Grbl 0.9j [’$’ for help]
[’$H’|’$X’ to unlock]
$$ < $0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=5 (dir port invert mask:00000101)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=842.000 (x, step/mm)
$101=846.2023 (y, step/mm)
$102=761.000 (z, step/mm)
$110=1000.000 (x max rate, mm/min)
$111=1000.000 (y max rate, mm/min)
$112=800.000 (z max rate, mm/min)
$120=20.000 (x accel, mm/sec^2)
$121=20.000 (y accel, mm/sec^2)
$122=20.000 (z accel, mm/sec^2)
$130=250.000 (x max travel, mm)
$131=250.000 (y max travel, mm)
$132=200.000 (z max travel, mm)

Possibly decrease values for $120-$121=122 down to 5.000 if the stepper motors start to stall. My machine seems to work well with these settings.

These settings are great information for the Woodpecker machine, however, if you try using those step/mm settings on an Xcarve, the machine will try to plunge through the spoil board and down into whatever table you have the thing set up on… or try to run off the rails in the x/y directions…

average step/mm for the X-Carve are in the 40s (X/Y axis) and around 180-190 (Z axis)

Thanks guys for the additional information. I’m working on the calibration spreadsheet now